Bug 107049 - nfs mount of SnapServer partition produces I/O errors
Summary: nfs mount of SnapServer partition produces I/O errors
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: nfs-utils (Show other bugs)
(Show other bugs)
Version: 9
Hardware: i686 Linux
medium
high
Target Milestone: ---
Assignee: Steve Dickson
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-14 16:00 UTC by John Rivlin
Modified: 2007-04-18 16:58 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-16 00:40:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Rivlin 2003-10-14 16:00:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 
1.0.3705; .NET CLR 1.1.4322)

Description of problem:
I have an nfs mounted a partition on a SnapAppliance SnapServer 4100 (I think 
its FreeBSD under the covers). I get I/O errors when copying files from the 
SnapServer to the Linx 9 installation. I also sometimes get data corruption. 
Repeating the same copy multiple times will work sometimes and fail others. In 
addition, a Thiz Linuz 7.0 installation I have works just fine with the same 
SnapAppliance SnapServer.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. mount snap server partition (mount 192.168.168.101:/root /snap1)
2. cp -r from to


Actual Results:  Get I/O error on some copied files. Also some files are 
corrupted on the destination machine.

Expected Results:  Expect not to get errors

Additional info:

Copying the same file twice does not produce the same output.

Comment 1 Steve Dickson 2003-10-15 13:59:06 UTC
What transport are you using UDP or TCP?
Are you using Soft mounts?

Comment 2 John Rivlin 2003-10-15 15:23:33 UTC
I'm using UDP. I've tried both soft and hard mounts. I tried TCP as well but 
got "mount: RPC: program not registered" from the mount command.

Comment 3 Steve Dickson 2003-10-19 01:28:00 UTC
Would it be possible to get a ethereal trace of the problem?

Comment 4 John Rivlin 2003-10-19 01:56:38 UTC
Not really. I decided to try installing Red Had Enterprise ES and just 
discovered that that resolved the problem.

Comment 5 Dan Baxter 2004-01-03 21:55:06 UTC
I had a similar problem with 2.4.20-27.7 and 2.4.20-24.7 but not
2.4.18-3smp (different machine), all RH7.3, connected to a SnapServer
1100.  After I added the mount option -o nfsvers=2, the problem seems
to have disappeared.

Comment 6 Steve Dickson 2004-01-04 23:58:21 UTC
The only way to decisively tell why nfsv3 breaks a SnapServer is to
have get a network trace. I need to see which NFS op is failing


Note You need to log in before you can comment on or make changes to this bug.