Bug 1070585 - "Proxy Configuration" window will write the proxy url to rhsm.conf even connection test is failed
Summary: "Proxy Configuration" window will write the proxy url to rhsm.conf even conne...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 7.1
Assignee: Chris "Ceiu" Rog
QA Contact: John Sefler
URL:
Whiteboard:
Keywords:
: 1176522 (view as bug list)
Depends On:
Blocks: rhsm-rhel71 1090838
TreeView+ depends on / blocked
 
Reported: 2014-02-27 07:38 UTC by xingge
Modified: 2016-09-20 02:28 UTC (History)
9 users (show)

(edit)
Clone Of:
: 1090838 (view as bug list)
(edit)
Last Closed: 2015-03-05 13:14:51 UTC


Attachments (Terms of Use)
check_persistance_of_invalid_proxy (171.43 KB, image/png)
2015-01-15 21:40 UTC, Sharath Dwaral
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0502 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2015-03-05 16:20:39 UTC

Description xingge 2014-02-27 07:38:05 UTC
Description of problem:
"Proxy Configuration" window will write the proxy url to rhsm.conf even connection test is failed

Version-Release number of selected component (if applicable):
subscription-manager-gui-1.10.14-3.el7
subscription-manager-firstboot-1.10.14-3.el7
subscription-manager-1.10.14-3.el7
python-rhsm-1.10.12-1.el7

How reproducible:
always

Steps to Reproduce:
1.Open the subscription-manager-gui
2.Open the Porxy Configuration window 
"System"-> "Configure Proxy"
3.select "I would like to connect via an HTTP proxy"
4.Input an invaild proxy url in "Proxy Location" like "www.redhat.com"
5.click "Test Connection"

Actual results:
Message "Proxy connection failed" showed on top of "Test Connetction" button
and in /etc/rhsm/rhsm.conf the proxy_hostname option is set to www.redhat.com

Expected results:
If the Test Connection failed the proxy_hostname in rhsm.conf should not be set.

Additional info:
If press "Test Connection" again after step5 the window will became un-responsible
and then CLI cmd will be un-resposible too.

Comment 1 Bryan Kearney 2014-03-19 20:52:31 UTC
Moving bugs from 7.0 to 7.1

Comment 3 Chris Snyder 2014-06-16 17:46:28 UTC
Should be in as of commit: 1176d1b08e90bd2dd739a1ef567b2f6e0c3f5354

Moving to post

Comment 4 Bryan Kearney 2014-07-30 19:24:07 UTC
Acking 7.1

Comment 7 Rehana 2014-11-24 09:06:45 UTC
Retested with ,

python-rhsm-1.13.8-1.el7.x86_64
subscription-manager-plugin-container-1.13.9-1.el7.x86_64
subscription-manager-migration-data-2.0.13-1.el7.noarch
subscription-manager-gui-1.13.9-1.el7.x86_64
subscription-manager-debuginfo-1.13.9-1.el7.x86_64
subscription-manager-1.13.9-1.el7.x86_64
subscription-manager-firstboot-1.13.9-1.el7.x86_64
subscription-manager-migration-1.13.9-1.el7.x86_64
subscription-manager-plugin-ostree-1.13.9-1.el7.x86_64


1) Observation on updating wrong proxy details : Observed that the rhsm.conf file was not updated when the "test connection" is failed.
However wrong proxy details are updated when you clik on "ok" button on the same window eventhough the window had the "proxy connection failed" message ==> Would like to confirm this behavior

2) Observation on multiple click on "Test connection": The application no-longer hangs when clicked multiple times on  "Test connection" button

Comment 8 John Sefler 2014-11-26 21:09:16 UTC
(In reply to Rehana from comment #7)

> 1) Observation on updating wrong proxy details : Observed that the rhsm.conf
> file was not updated when the "test connection" is failed.
> However wrong proxy details are updated when you clik on "ok" button on the
> same window eventhough the window had the "proxy connection failed" message
> ==> Would like to confirm this behavior


In this case you explicitly clicked "Ok" which implies that you are okay with the http proxy values that you set in the dialog.  If you were not okay with the values after having clicked "Test Connection", then you should have "Cancel"ed the dialog.  I believe this is working as designed, yet I understand the frustration.  I would suggest that the "Ok" button label be changed to "Save" to help make the consequence of clicking that button more obvious.

Moving bug back to NEW/FailedQA to change the label on the "Ok" button to "Save".

Comment 9 Chris "Ceiu" Rog 2014-12-19 13:57:31 UTC
commit 05c8eec8b77e509abc285fb6d2acd219f5f0af7f
Author: Chris Rog <crog@redhat.com>
Date:   Fri Dec 12 13:45:45 2014 -0500

    1070585: Changed button label from "Ok" to "Save"

Comment 12 Sharath Dwaral 2015-01-15 21:40:15 UTC
Created attachment 980646 [details]
check_persistance_of_invalid_proxy

Version:

# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.38-1
subscription management rules: 5.13
subscription-manager: 1.13.16-1.el7
python-rhsm: 1.13.10-1.el7

Verification:

Test 1: Enter Invalid Proxy
        Click Test Connection
        Check rhsm.conf file for persistance

        Invalid proxy is not written in rhsm.conf

Test 2: Enter Invalid Proxy
        Click Save
        Check rhsm.conf file for persistance

        Invalid proxy is "saved" in rhsm.conf

Test 3: Open Proxy Configuration
        OK button should now bw "Save"

        Please see attachment for verification.

VERIFIED

Comment 13 William Poteat 2015-01-16 14:54:09 UTC
*** Bug 1176522 has been marked as a duplicate of this bug. ***

Comment 15 errata-xmlrpc 2015-03-05 13:14:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0502.html


Note You need to log in before you can comment on or make changes to this bug.