Bug 1070598 - problems downloading large files (and counting past 100%)
problems downloading large files (and counting past 100%)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-02-27 03:16 EST by Ben Boeckel
Modified: 2014-09-30 19:42 EDT (History)
4 users (show)

See Also:
Fixed In Version: dnf-0.4.17-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-07 22:35:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dnf giving it 106% (32.15 KB, image/png)
2014-02-27 03:21 EST, Ben Boeckel
no flags Details

  None (edit)
Description Ben Boeckel 2014-02-27 03:16:18 EST
Not really sure what is happening here. The summary said the whole update was 992 MB and dnf is happily counting up to 1.2 GB so far (and the output is unhappy; screenshots attached).

Version-Release number of selected component (if applicable):
dnf-0.4.15-1.fc21.noarch
Comment 1 Ben Boeckel 2014-02-27 03:21:12 EST
Created attachment 868348 [details]
dnf giving it 106%

Things to note:

  * Counting past 100%
  * ETA is gone
  * The progress bar keeps growing and pushing the rest off to the right.

Looking in the cache, it appears as though the file in question is only 36 MB in size and there are occasional timeout error messages popping up in the stream, so is the file being deleted but the download progress not being updated?
Comment 2 Radek Holy 2014-02-27 08:45:51 EST
Hello, thank you for the report. I cannot reproduce it here, however we'll take a look at it.
Comment 3 Radek Holy 2014-03-03 03:20:38 EST
Another reproducer seen here: https://bugzilla.redhat.com/show_bug.cgi?id=1071518#c1
Comment 4 Ben Boeckel 2014-03-03 12:52:20 EST
Yeah, I've also seen the behavior shown in that bug's initial comment, but haven't gotten around to posting it.
Comment 5 Ales Kozumplik 2014-03-04 04:08:05 EST
Counting past 100% fixed by 68e591c on master.

Ben, if you want to you can test how the fix works before an official release using our nightly builds: 

jenkins.cloud.fedoraproject.org/job/DNF/lastSuccessfulBuild/artifact/
Comment 6 Fedora Update System 2014-03-05 07:57:23 EST
dnf-0.4.17-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dnf-0.4.17-1.fc20
Comment 7 Fedora Update System 2014-03-06 03:14:09 EST
Package dnf-0.4.17-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-0.4.17-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-3465/dnf-0.4.17-1.fc20
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2014-03-07 22:35:26 EST
dnf-0.4.17-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.