Bug 1070638 - Org creation using normal user doesn't populate the org name in selection list
Summary: Org creation using normal user doesn't populate the org name in selection list
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: WebUI
Version: Nightly
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: jmagen@redhat.com
QA Contact: Katello QA List
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-27 10:00 UTC by Sachin Ghai
Modified: 2019-09-26 13:44 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-11 12:29:31 UTC
Target Upstream Version:


Attachments (Terms of Use)
org selection busted with normal user (79.93 KB, image/png)
2014-02-27 10:00 UTC, Sachin Ghai
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 5854 0 None None None 2016-04-22 16:20:42 UTC

Description Sachin Ghai 2014-02-27 10:00:57 UTC
Created attachment 868423 [details]
org selection busted with normal user

Description of problem:
I was trying org selection using normal user. I logged in with normal user (who has permissions to create org) and created an org. But I could not select it from left top org selection list. Looks like a rendering issue.

Version-Release number of selected component (if applicable):


How reproducible:
always
using Firefox 26.0
also with chrome Version 32.0.1700.107

Steps to Reproduce:
1. login with admin user and create a normal user
2. create a role and assign all org related permissions to it
3. assign the role created in setp2 to normal user
4. login with normal user
5. create organization
6. select org from top left selection list

Actual results:
UI doesn't show created org

Expected results:
Org should be selected from the selection list

Additional info:
With admin user, I don't find any such issue.

Comment 1 Sachin Ghai 2014-02-27 10:05:00 UTC
the build version:

katello-certs-tools-1.5.1-1.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
rubygem-katello_api-0.0.8-1.el6.noarch
ruby193-rubygem-katello-1.5.0-10.201402261852git11c1eb1.el6.noarch
pulp-katello-plugins-0.2-1.el6.noarch
katello-1.5.0-14.201402261852git11c1eb1.el6.noarch
rubygem-hammer_cli_katello-0.0.3-1.el6.noarch
katello-installer-0.0.19-1.201402251400gitca01fc3.el6.noarch
katello-repos-1.5.1-1.git.14.0868bd1.el6.noarch
rubygem-foreman_api-0.1.11-1.el6.noarch
foreman-proxy-1.5.0-0.develop.201402201704gita25e7b9.el6.noarch
rubygem-hammer_cli_foreman-0.0.18-1.el6.noarch
ruby193-rubygem-foreman-tasks-0.3.1-1.el6.noarch
foreman-postgresql-1.5.0-0.develop.201402250936git8cf1033.el6.noarch
foreman-release-1.5.0-0.develop.201402250936git8cf1033.el6.noarch
foreman-selinux-1.5.0-0.develop.201402261344git2f43f94.el6.noarch
foreman-1.5.0-0.develop.201402250936git8cf1033.el6.noarch

Comment 2 RHEL Program Management 2014-02-27 10:29:40 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 6 jmagen@redhat.com 2014-05-22 07:07:07 UTC
wrong PR above. check this one

https://github.com/theforeman/foreman/pull/1463

Comment 7 Bryan Kearney 2014-06-20 10:02:00 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/5854 has been closed

Comment 10 sthirugn@redhat.com 2014-08-01 17:52:35 UTC
Verified.

Version Tested: 
Satellite-6.0.4-RHEL-6-20140730.0 (Sat6 GA Snap 3)

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.19-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.19-1.el6_5.noarch
* candlepin-tomcat6-0.9.19-1.el6_5.noarch
* elasticsearch-0.90.10-4.el6sat.noarch
* foreman-1.6.0.34-1.el6sat.noarch
* foreman-compute-1.6.0.34-1.el6sat.noarch
* foreman-gce-1.6.0.34-1.el6sat.noarch
* foreman-libvirt-1.6.0.34-1.el6sat.noarch
* foreman-ovirt-1.6.0.34-1.el6sat.noarch
* foreman-postgresql-1.6.0.34-1.el6sat.noarch
* foreman-proxy-1.6.0.23-1.el6sat.noarch
* foreman-selinux-1.6.0.4-1.el6sat.noarch
* foreman-vmware-1.6.0.34-1.el6sat.noarch
* katello-1.5.0-27.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.6-1.el6sat.noarch
* katello-installer-0.0.56-1.el6sat.noarch
* openldap-2.4.23-34.el6_5.1.x86_64
* pulp-katello-0.3-3.el6sat.noarch
* pulp-nodes-common-2.4.0-0.23.beta.el6sat.noarch
* pulp-nodes-parent-2.4.0-0.23.beta.el6sat.noarch
* pulp-puppet-plugins-2.4.0-0.23.beta.el6sat.noarch
* pulp-puppet-tools-2.4.0-0.23.beta.el6sat.noarch
* pulp-rpm-plugins-2.4.0-0.23.beta.el6sat.noarch
* pulp-selinux-2.4.0-0.23.beta.el6sat.noarch
* pulp-server-2.4.0-0.23.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch
* sssd-ldap-1.11.5.1-3.el6.x86_64

Comment 12 Bryan Kearney 2014-09-11 12:29:31 UTC
This was delivered with Satellite 6.0 which was released on 10 September 2014.


Note You need to log in before you can comment on or make changes to this bug.