Bug 107082 - swsup crashes during suspend to disk
swsup crashes during suspend to disk
Status: CLOSED DUPLICATE of bug 126342
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-14 16:22 EDT by Dan Berger
Modified: 2015-01-04 17:03 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-29 23:31:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Berger 2003-10-14 16:22:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030701
Galeon/1.3.9

Description of problem:
I suspect this should be filed in the kernel.org bugzilla, but I'm filing it
here first.  (In other words, feel free to punt it.)

I added the following config entries to the test7 i686 config:

CONFIG_SOFTWARE_SUSPEND=y
CONFIG_ACPI_SLEEP=y
CONFIG_ACPI_SLEEP_PROC_FS=y

and changed the ACPI bits (AC, BATTERY, BUTTON, FAN, PROCESSOR, THERMAL) from
modules to in-built.

I've run into several bugs related to switching to sleep mode S1, but they've
already been reported.  This bug, however, I haven't found any mention of
anywhere (kernel.org's bugzilla, redhat's bugzilla, or google)

Version-Release number of selected component (if applicable):
kernel-2.6.0-0.test7.1.52

How reproducible:
Always

Steps to Reproduce:
1. modify the kernel config as described above, rebuild and install
2. echo 4 > /proc/acpi/sleep

    

Actual Results:  the last few lines displayed are:

hda: completing PM request, suspend
waiting for DMA's to settle down...

double fault, gdt @ c02ed900 [255 bytes]
double fault, tss @ c0361800

eip=c024731e, esp=0
eax=0, ebx=0, ecx=0, edx=0
esi=0, edi=0

And the machine stops responding. 

Additional info:
Comment 1 Dave Jones 2004-10-29 23:31:56 EDT

*** This bug has been marked as a duplicate of 126342 ***

Note You need to log in before you can comment on or make changes to this bug.