Due to a recent update on Javascript code a full page refresh on your browser might be needed.
Bug 1070874 - Exchange is not created when dynamic flag is used
Summary: Exchange is not created when dynamic flag is used
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp
Version: Development
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: 3.1
: ---
Assignee: Gordon Sim
QA Contact: Petr Matousek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-27 16:02 UTC by Petr Matousek
Modified: 2015-04-14 13:47 UTC (History)
2 users (show)

Fixed In Version: qpid-cpp-0.30-2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-14 13:47:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Apache JIRA QPID-5707 None None None Never
Red Hat Bugzilla 1086810 None None None Never
Red Hat Bugzilla 1086816 None None None Never
Red Hat Product Errata RHEA-2015:0805 normal SHIPPED_LIVE Red Hat Enterprise MRG Messaging 3.1 Release 2015-04-14 17:45:54 UTC

Internal Links: 1086810 1086816

Description Petr Matousek 2014-02-27 16:02:01 UTC
Description of problem:

When using a dynamic flag for creating exchange, the exchange is not
created using 0-10, ie:

./spout "#node1;{node:{type:topic}}"
Exchange not found exception
(same behavior when receiver is used)

With regard that all of the commands below creates the node and send messages towards it, this is needlessly inconsistent.

./spout "#node1;{node:{type:queue}}" --connection-options "{protocol:amqp1.0}"
./spout "#node1;{node:{type:topic}}" --connection-options "{protocol:amqp1.0}"
./spout "#node1;{node:{type:queue}}"

Version-Release number of selected component (if applicable):
qpid-cpp-server-*-0.22-35

How reproducible:
100%

Steps to Reproduce:
1. ./spout "#node1;{node:{type:topic}}"
2. Exchange not found exception


Actual results:
Exchange not found exception

Expected results:
The exchange is created, meesages are sent towards it, the exchange is removed on link close

Additional info:

Comment 1 Gordon Sim 2014-04-16 19:29:58 UTC
Fixed upstream: https://svn.apache.org/r1588001

Comment 3 Petr Matousek 2015-01-21 16:30:53 UTC
This issue has been fixed. Verified on rhel6.6 (x86_64 and i386)

Packages:
qpid-cpp-*-0.30-5

-> VERIFIED

Comment 5 errata-xmlrpc 2015-04-14 13:47:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0805.html


Note You need to log in before you can comment on or make changes to this bug.