Bug 1070892 - FTBFS: region_specific_language self check failed
Summary: FTBFS: region_specific_language self check failed
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: libreport
Version: rawhide
Hardware: powerpc
OS: Linux
medium
high
Target Milestone: ---
Assignee: abrt
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: PPCTracker
TreeView+ depends on / blocked
 
Reported: 2014-02-27 16:33 UTC by Karsten Hopp
Modified: 2014-03-07 13:24 UTC (History)
7 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-03-07 13:24:17 UTC


Attachments (Terms of Use)
testsuite.log (68.67 KB, text/plain)
2014-02-27 16:33 UTC, Karsten Hopp
no flags Details
build.log (314.26 KB, text/plain)
2014-02-27 16:33 UTC, Karsten Hopp
no flags Details

Description Karsten Hopp 2014-02-27 16:33:00 UTC
Created attachment 868631 [details]
testsuite.log

Description of problem:
libreport types
 21: string_vector                                   ok
 22: map_string_get_set_as_various_types             ok
XML definitions
 23: region_specific_language                        FAILED (xml_definition.at:9)
## ------------- ##
## Test results. ##
## ------------- ##
ERROR: All 23 tests were run,
1 failed unexpectedly.

Version-Release number of selected component (if applicable):
libreport-2.1.12-2.fc21

How reproducible:


Steps to Reproduce:
1. ppc-koji build --scratch f21 libreport-2.1.12-2.fc21.src.rpm
2.
3.

Actual results:
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=1682909

Expected results:


Additional info:

Comment 1 Karsten Hopp 2014-02-27 16:33:38 UTC
Created attachment 868632 [details]
build.log

Comment 2 Jakub Filak 2014-03-05 09:23:47 UTC
I did some investigation and it looks like that Fedora rawhide on ppc doesn't support localization: every call of setlocale(LC_ALL, "zh_CN") fails. Any idea how to fix this?

Comment 3 Karsten Hopp 2014-03-05 13:16:58 UTC
I'm not sure what is going on, looks like some temporary problem as another attempt to build libreport-2.1.12-2.fc21 succeeded: http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=1700326

Comment 4 Jakub Filak 2014-03-07 13:24:17 UTC
(In reply to Karsten Hopp from comment #3)
> I'm not sure what is going on, looks like some temporary problem as another
> attempt to build libreport-2.1.12-2.fc21 succeeded:
> http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=1700326

Another build succeeded:
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=1704662

Closing as WORKSFORME.


Note You need to log in before you can comment on or make changes to this bug.