Bug 10709 - When printing a specific combination of text, error messages result.
When printing a specific combination of text, error messages result.
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: printtool (Show other bugs)
6.1
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Crutcher Dunnavant
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-10 17:17 EDT by tastin
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-07 17:03:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tastin 2000-04-10 17:17:55 EDT
I am using RH 6.1 for intel on a Pentium II 333, 64megs ram, 4.3gig UDMA
drive.  The printer involved is a Minolta Pageworks 20, used as a HP4, as
it is built to be compatible with such.  It is a local printer on lp0.
All else works fine, but when the following two lines of text are used in
a WP 5.1 merge document:

IMPERIAL HOMES
FAIRMONT PARK EAST

the message:  No way to print this type of input file: IR-channel
Fasttracker "ok    appears at the top of the page.

I commented out the lines in the filter script that dump unrecognized file
types with this message.  The pages then printed normally.  We are using
dosemu .98.0 on top of RH6.1.  I used printtool to select the hp4/5/6
driver and tested it out as ok.  The other several thousand pages of
printing we have done so far print without trouble.  Just this particular
bit of text.  I tried removing the rest of the text, just to be sure.  One
other combo of text, that I can't get a copy of, apparently generated a
completely blank page.  I could'nt repeat that one though.  Anyone heard
of this?  This is trivial enough, but could be a problem if other combos
have this sort of effect.  Thanks for your time.

Jeff Hogg
Comment 1 tastin 2000-04-11 18:54:59 EDT
I dug a little deeper into the printing system and found out a bit more.  In
the file /usr/share/magic, The audio section is listed in the file twice in a
row.  I removed the duplication.  This had no effect.  I then deleted the part
in the remaining audio file section that says "Taken from loader code from
mikmod version 2.14 by Steve McIntyre"  This removed the entry that my document
was being confused with, and resulted in a normal print.  The entry in
particular is "
>1080   string   >/0   %.2s-channel Fasttracker "oktalyzer" module sound data

I doubt I will ever need this one myself, so I'm fine without it.  My document
apparently is normally seen as this entry:

0   string   \033%-12345X@PJL    HP Printer Job Language data

Hope this helps clarify this thing.

Jeff Hogg
Comment 2 Crutcher Dunnavant 2000-08-08 15:13:23 EDT
This looks like a very rare failure of the magic system.
I am going to close this for now, and if it happens again,
I'll remove the entry from magic.

Note You need to log in before you can comment on or make changes to this bug.