Bug 107108 - kssl.h won't compile
Summary: kssl.h won't compile
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: openssl   
(Show other bugs)
Version: 2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-15 04:03 UTC by Kevin DeKorte
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-21 16:51:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kevin DeKorte 2003-10-15 04:03:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030811
Mozilla Firebird/0.6.1

Description of problem:
Compiling kssh.h with gcc 3.3.1 results in 

In file included from /usr/include/openssl/ssl.h:179,
                 from internet.h:36,
                 from cookie.c:39:
/usr/include/openssl/kssl.h:136: error: syntax error before '*' token

in kssl.h the line

        krb5_octet FAR *key;

in

typedef struct kssl_ctx_st
        {
                                /*      used by:    disposition:            */
        char *service_name;     /*      C,S         default ok (kssl)       */
        char *service_host;     /*      C           input, REQUIRED         */
        char *client_princ;     /*      S           output from krb5 ticket */
        char *keytab_file;      /*      S           NULL (/etc/krb5.keytab) */
        char *cred_cache;       /*      C           NULL (default)          */
        krb5_enctype enctype;
        int length;
        krb5_octet FAR *key;
        } KSSL_CTX;


Looks like gcc 3.3.1 does not like the FAR option

Version-Release number of selected component (if applicable):
openssl-devel 0.9.7

How reproducible:
Always

Steps to Reproduce:
1. compile wine
2.
3.
    

Actual Results:  In file included from /usr/include/openssl/ssl.h:179,
                 from internet.h:36,
                 from cookie.c:39:
/usr/include/openssl/kssl.h:136: error: syntax error before '*' token
/usr/include/openssl/kssl.h:149: error: syntax error before '*' token
/usr/include/openssl/kssl.h:150: error: syntax error before '*' token
/usr/include/openssl/kssl.h:151: error: syntax error before '*' token
/usr/include/openssl/kssl.h:151: error: syntax error before '*' token
/usr/include/openssl/kssl.h:152: error: syntax error before '*' token
/usr/include/openssl/kssl.h:153: error: syntax error before '*' token
/usr/include/openssl/kssl.h:155: error: syntax error before '*' token
/usr/include/openssl/kssl.h:157: error: syntax error before '*' token
/usr/include/openssl/kssl.h:159: error: syntax error before '*' token
/usr/include/openssl/kssl.h:167: error: syntax error before '*' token
In file included from internet.h:36,
                 from cookie.c:39:
/usr/include/openssl/ssl.h:909: error: syntax error before "KSSL_CTX"
/usr/include/openssl/ssl.h:931: error: syntax error before '}' token
make[2]: *** [cookie.o] Error 1
make[2]: Leaving directory `/home/kdekorte/cvs/wine/dlls/wininet'
make[1]: *** [wininet] Error 2
make[1]: Leaving directory `/home/kdekorte/cvs/wine/dlls'
make: *** [dlls] Error 2


Expected Results:  clean compile

Comment 1 Alan Cox 2004-06-21 16:51:58 UTC
Testing FC2 seems ok



Note You need to log in before you can comment on or make changes to this bug.