Bug 1071094 - [abrt] byobu: config.py:215:writestatus:IOError: [Errno 2] 没有那个文件或目录: '/root/.byobu/status'
Summary: [abrt] byobu: config.py:215:writestatus:IOError: [Errno 2] 没有那个文件或目录: '/root/...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: byobu
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Klepek
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:c114735fd8a0bf139a83c0bd46a...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-28 05:21 UTC by lnie
Modified: 2015-03-28 19:56 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-28 19:56:09 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (1.77 KB, text/plain)
2014-02-28 05:21 UTC, lnie
no flags Details
File: environ (3.83 KB, text/plain)
2014-02-28 05:21 UTC, lnie
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1286249 0 None None None Never

Description lnie 2014-02-28 05:21:35 UTC
Description of problem:
1 try to remove  time in byobu-config
2 choose <Apply>
3 push the Enter button

Version-Release number of selected component:
byobu-5.69-2.fc20

Additional info:
reporter:       libreport-2.1.12
cmdline:        python /usr/libexec/byobu/include/config.py
executable:     /usr/libexec/byobu/include/config.py
kernel:         3.11.10-301.fc20.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
config.py:215:writestatus:IOError: [Errno 2] 没有那个文件或目录: '/root/.byobu/status'

Traceback (most recent call last):
  File "/usr/libexec/byobu/include/config.py", line 385, in <module>
    main()
  File "/usr/libexec/byobu/include/config.py", line 374, in main
    tag = togglestatus(snackScreen, size)
  File "/usr/libexec/byobu/include/config.py", line 248, in togglestatus
    writestatus(itemlist)
  File "/usr/libexec/byobu/include/config.py", line 215, in writestatus
    f = open(path, "r")
IOError: [Errno 2] 没有那个文件或目录: '/root/.byobu/status'

Local variables in innermost frame:
i: [0, 'wifi_quality']
path: '/root/.byobu/status'
status: {'ec2_cost': 0, 'battery': 0, 'cpu_count': 1, 'services': 0, 'session': 0, 'entropy': 0, 'logo': 1, 'disk': 0, 'uptime': 1, 'cpu_freq': 1, 'disk_io': 0, 'arch': 0, 'hostname': 0, 'custom': 0, 'swap': 0, 'memory': 1, 'apport': 0, 'mail': 0, 'wifi_quality': 0, 'distro': 0, 'load_average': 1, 'raid': 1, 'users': 0, 'updates_available': 1, 'reboot_required': 1, 'date': 0, 'ip_address': 0, 'network': 0, 'processes': 0, 'time_utc': 0, 'cpu_temp': 0, 'fan_speed': 0, 'rcs_cost': 0, 'time': 1, 'release': 1, 'whoami': 0}
key: 'tmux_left'
items: [[0, 'apport'], [0, 'arch'], [0, 'battery'], [1, 'cpu_count'], [1, 'cpu_freq'], [0, 'cpu_temp'], [0, 'custom'], [0, 'date'], [0, 'disk'], [0, 'disk_io'], [0, 'distro'], [0, 'ec2_cost'], [0, 'entropy'], [0, 'fan_speed'], [0, 'hostname'], [0, 'ip_address'], [1, 'load_average'], [1, 'logo'], [0, 'mail'], [1, 'memory'], [0, 'network'], [0, 'processes'], [1, 'raid'], [0, 'rcs_cost'], [1, 'reboot_required'], [1, 'release'], [0, 'services'], [0, 'session'], [0, 'swap'], [1, 'time'], [0, 'time_utc'], [1, 'updates_available'], [1, 'uptime'], [0, 'users'], [0, 'whoami'], [0, 'wifi_quality']]

Comment 1 lnie 2014-02-28 05:21:45 UTC
Created attachment 868819 [details]
File: backtrace

Comment 2 lnie 2014-02-28 05:21:48 UTC
Created attachment 868820 [details]
File: environ

Comment 3 lnie 2014-02-28 05:25:11 UTC
still see this crash in byobu-5.73-3.fc20

Comment 4 Jan Klepek 2014-02-28 08:00:06 UTC
unable to reproduce, it works correctly on my desktop, can you please translate IOError: [Errno 2] 没有那个文件或目录: '/root/.byobu/status' or set your OS language to English?

Comment 5 lnie 2014-02-28 08:20:14 UTC
sure, 没有那个文件或目录:No such file or directory.

Comment 6 Jan Klepek 2014-02-28 09:03:09 UTC
can you please copy whole /root/.byobu directory to /root/byobu_backup, remove /root/.byobu and once done please try to reproduce your issue. Please let me know the result.

Comment 7 Jan Klepek 2014-02-28 17:36:06 UTC
reported to upstream, patch provided, will be fixed in fedora/epel

Comment 8 Fedora Update System 2014-02-28 18:08:32 UTC
byobu-5.73-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/byobu-5.73-4.fc19

Comment 9 Fedora Update System 2014-02-28 18:08:52 UTC
byobu-5.73-4.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/byobu-5.73-4.el5

Comment 10 Fedora Update System 2014-02-28 18:09:20 UTC
byobu-5.73-4.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/byobu-5.73-4.el6

Comment 11 Fedora Update System 2014-02-28 18:09:43 UTC
byobu-5.73-4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/byobu-5.73-4.fc20

Comment 12 lnie 2014-03-03 04:34:23 UTC
Thanks for the quick fix

Comment 13 Fedora Update System 2014-03-15 19:51:19 UTC
byobu-5.73-4.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2014-03-15 19:51:44 UTC
byobu-5.73-4.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2014-03-17 03:55:26 UTC
byobu-5.73-4.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2014-03-17 03:56:19 UTC
byobu-5.73-4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.