Bug 107111 - Nautilus Progress Bar when copying large amounts/large files goes to 100% prematurely
Nautilus Progress Bar when copying large amounts/large files goes to 100% pre...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
rawhide
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
: MoveUpstream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-15 01:50 EDT by Steven Harms
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-04 10:09:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of error (23.73 KB, image/png)
2003-10-15 02:00 EDT, Steven Harms
no flags Details
Screenshot of progress bar from local harddrive to local harddrive (9.05 KB, image/png)
2003-10-15 07:31 EDT, Steven Harms
no flags Details

  None (edit)
Description Steven Harms 2003-10-15 01:50:55 EDT
Description of problem:
Progress bar moves to end prematurely.  Ex.  It looks like after only a few
files that it is finished when it has over 1000 more to go.

Version-Release number of selected component (if applicable):
Nautilus 2.4.0

How reproducible:
Copy a large amount of files, or a folder, from one place to another.  In this
instance I copied a mp3 folder from my ntfs partition to my fedora desktop.

Steps to Reproduce:
1. Copy a folder
2.
3.
    
Actual results:
Progress bar shows its done before it is

Expected results:
Progress bar should gradually fill up

Additional info:
Comment 1 Steven Harms 2003-10-15 02:00:58 EDT
Created attachment 95185 [details]
Screenshot of error

The progress bar should clearly not be anywhere near done.  This actually
happens after the first few but I didnt get around to making a screenshot of it
until the 100th or so file.
Comment 2 Alexander Larsson 2003-10-15 05:14:19 EDT
Does this happen even when you copy from a non-ntfs partition?
I just tried copying /usr/lib to ~/newdir, and i didn't see this.
Comment 3 Alexander Larsson 2003-10-15 05:24:17 EDT
Also, i think we progress according to size, not file-count, so maybe you had a
very large file first, or perhaps the file-size handling on NTFS is buggy.
Comment 4 Steven Harms 2003-10-15 07:31:42 EDT
Created attachment 95202 [details]
Screenshot of progress bar from local harddrive to local harddrive

Here is a screenshot produced by copying a folder by right clicking it, hitting
copy, then going up 1 level and pasting it.  Also note that the folder has 170
items, ranging from the largest of 440mb, down to the smallest of 512k, with a
total of 8.2GB worth of files.	The average filesize is around 60mb.  Partition
is ext3.
Comment 5 Alexander Larsson 2006-09-04 10:09:34 EDT
I believe this has been fixed in recent versions of gnome-vfs. Reopen if you see
this in rawhide/FC6.

Note You need to log in before you can comment on or make changes to this bug.