This service will be undergoing maintenance at 03:30 UTC, 2016-05-27. It is expected to last about 2 hours
Bug 1071174 - tests failing on big endians
tests failing on big endians
Status: CLOSED DUPLICATE of bug 919030
Product: Fedora
Classification: Fedora
Component: perl-Glib-Object-Introspection (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ZedoraTracker
  Show dependency treegraph
 
Reported: 2014-02-28 03:16 EST by Dan Horák
Modified: 2014-02-28 03:37 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-28 03:37:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dan Horák 2014-02-28 03:16:13 EST
some tests are failing on big endian arches like s390 and ppc

Executing(%check): /bin/sh -e /var/tmp/rpm-tmp.GcyeBA
+ umask 022
+ cd /builddir/build/BUILD
+ cd Glib-Object-Introspection-0.016
+ LANG=en_US.UTF8
+ make test
LD_LIBRARY_PATH=:build PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
#   Failed test at t/00-basic-types.t line 15.
#          got: '-1'
#     expected: '-127'
#   Failed test at t/00-basic-types.t line 16.
#          got: '0'
#     expected: '255'
#   Failed test at t/00-basic-types.t line 17.
#          got: '-1'
#     expected: '-32767'
#   Failed test at t/00-basic-types.t line 18.
#          got: '0'
#     expected: '65535'
# Looks like you failed 4 tests of 34.
t/00-basic-types.t ............ 
Dubious, test returned 4 (wstat 1024, 0x400)
Failed 4/34 subtests 
#   Failed test at t/arg-checks.t line 11.
#          got: '-1'
#     expected: '-127'
#   Failed test at t/arg-checks.t line 21.
#          got: '0'
#     expected: '127'
# Looks like you failed 2 tests of 5.
t/arg-checks.t ................ 
Dubious, test returned 2 (wstat 512, 0x200)
Failed 2/5 subtests 
t/arrays.t .................... ok
t/boxed.t ..................... ok
t/cairo-integration.t ......... ok
t/callbacks.t ................. ok
t/closures.t .................. ok
t/constants.t ................. ok
t/enums.t ..................... ok
t/hashes.t .................... ok
t/interface-implementation.t .. ok
t/objects.t ................... ok
t/structs.t ................... ok
t/values.t .................... ok
t/vfunc-chaining.t ............ ok
t/vfunc-ref-counting.t ........ ok
Test Summary Report
-------------------
t/00-basic-types.t          (Wstat: 1024 Tests: 34 Failed: 4)
  Failed tests:  3-6
  Non-zero exit status: 4
t/arg-checks.t              (Wstat: 512 Tests: 5 Failed: 2)
  Failed tests:  1, 5
  Non-zero exit status: 2
Files=16, Tests=326,  1 wallclock secs ( 0.06 usr  0.01 sys +  0.49 cusr  0.11 csys =  0.67 CPU)
Result: FAIL
Failed 2/16 test programs. 6/326 subtests failed.
make: *** [test_dynamic] Error 255

for full logs please see
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=1680641
http://s390.koji.fedoraproject.org/koji/taskinfo?taskID=1358585

Version-Release number of selected component (if applicable):
perl-Glib-Object-Introspection-0.016-1.fc20
Comment 1 Dan Horák 2014-02-28 03:37:58 EST

*** This bug has been marked as a duplicate of bug 919030 ***

Note You need to log in before you can comment on or make changes to this bug.