Bug 1071278 - systemd picked up a build dependency libseccomp that isn't available on all arches
Summary: systemd picked up a build dependency libseccomp that isn't available on all a...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: rawhide
Hardware: powerpc
OS: Linux
high
high
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: PPCTracker
TreeView+ depends on / blocked
 
Reported: 2014-02-28 12:36 UTC by Karsten Hopp
Modified: 2014-06-17 12:14 UTC (History)
7 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-06-17 12:14:12 UTC


Attachments (Terms of Use)
root.log with libseccomp build requirement (75.90 KB, text/plain)
2014-02-28 12:36 UTC, Karsten Hopp
no flags Details
build.log with libseccomp requirement disabled (2.17 MB, text/plain)
2014-02-28 12:37 UTC, Karsten Hopp
no flags Details

Description Karsten Hopp 2014-02-28 12:36:04 UTC
Created attachment 869015 [details]
root.log with libseccomp build requirement

Description of problem:
systemd-210 has a build requirement libseccomp which isn't available on PPC and PPC64. Disabling that requirement doesn't work either:

...
/tmp/ccNlyYHl.ltrans3.ltrans.o:(.opd+0x10): multiple definition of `sd_pid_get_machine_name'
libsystemd_internal_la-sd-login.o (symbol from plugin):(.text+0x0): first defined here
/tmp/ccNlyYHl.ltrans3.ltrans.o:(.opd+0x20): multiple definition of `sd_pid_get_user_unit'
libsystemd_internal_la-sd-login.o (symbol from plugin):(.text+0x0): first defined here
/tmp/ccNlyYHl.ltrans3.ltrans.o:(.opd+0x30): multiple definition of `sd_pid_get_unit'
libsystemd_internal_la-sd-login.o (symbol from plugin):(.text+0x0): first defined here
...
collect2: error: ld returned 1 exit status
make[2]: *** [libsystemd-login.la] Error 1

Version-Release number of selected component (if applicable):
systemd-210-2.fc21

How reproducible:
always

Steps to Reproduce:
1. ppc-koji build --scratch f21 systemd-210-2.fc21.src.rpm
2.
3.

Actual results:
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=1686956

Expected results:


Additional info:

Comment 1 Karsten Hopp 2014-02-28 12:37:46 UTC
Created attachment 869016 [details]
build.log with libseccomp requirement disabled

Comment 2 Karsten Hopp 2014-02-28 20:52:03 UTC
I've opened bug 1071284 to get ppc* support into libseccomp. Looks like we need a workaround in systemd until the kernel gets  BPF seccomp filter support.

Comment 3 Zbigniew Jędrzejewski-Szmek 2014-03-01 03:41:01 UTC
Your build problems aren't related to the lack of libseccomp afaics. I pushed a work-around as systemd-210-3. Please check that it works for you, but do *not* build it officially yet, because there's some more fixes that should go into 210-3 (tomorrow or Sunday).

Comment 4 Zbigniew Jędrzejewski-Szmek 2014-03-01 13:22:56 UTC
Current rawhide version should build on ppc.

Comment 5 Karsten Hopp 2014-03-03 12:25:41 UTC
A scratch build succeeded: http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=1695760 . But as 210-3 is in koji now, I think it is ok to build it officially now, correct ?

Comment 6 Zbigniew Jędrzejewski-Szmek 2014-03-03 13:05:19 UTC
(In reply to Karsten Hopp from comment #5)
> A scratch build succeeded:
> http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=1695760 . But as
> 210-3 is in koji now, I think it is ok to build it officially now, correct ?
Yes.

Comment 7 Lennart Poettering 2014-06-17 12:14:12 UTC
Appears to be fixed. Closing.


Note You need to log in before you can comment on or make changes to this bug.