Bug 107128 - Cannot go higher than 800*600 with Permedia2
Cannot go higher than 800*600 with Permedia2
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: redhat-config-xfree86 (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-15 04:46 EDT by Rainer Traut
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-16 15:20:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XF86 config (3.16 KB, text/plain)
2003-10-15 04:47 EDT, Rainer Traut
no flags Details
XF86 log (34.02 KB, text/plain)
2003-10-15 04:49 EDT, Rainer Traut
no flags Details

  None (edit)
Description Rainer Traut 2003-10-15 04:46:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031014

Description of problem:
Del Optiplex GX260, i845 g/gl chipset, onboard graphics disabled by plugging in:
Diamond Fire GL1000, 3Dlabs Premedia2, under RHL I was able to do 1024*768, now
I an only click on 800*600, not higher.
RHL9 was ok.

Version-Release number of selected component (if applicable):
redhat-config-xfree86-0.9.9-2

How reproducible:
Always

Steps to Reproduce:
1. install with Permedia2 card
2. run rh-xfree86-config
3. no resolution higher than 800*600
    

Actual Results:  800*600 runs fine with 85hz refresh

Expected Results:  1024*768 75hz

Additional info:
Comment 1 Rainer Traut 2003-10-15 04:47:22 EDT
Created attachment 95191 [details]
XF86 config
Comment 2 Rainer Traut 2003-10-15 04:49:04 EDT
Created attachment 95192 [details]
XF86 log
Comment 3 Brent Fox 2003-10-15 15:22:10 EDT
I have a Permedia2 in my test machine and the tool behaves properly.  The config
tool tries to determine the available resolutions based on the amount of probed
video card memory and the monitor refresh rates.  Sometimes if the monitor
cannot be probed properly, the tool will default to a Generic monitor with a low
refresh rate which causes the list of availabe resolutions to be limited.  In
this case, it is necessary to manuall select the correct monitor in order to see
more resolutions.

Try this:
1) delete /etc/X11/XF86Config (or move out of the way)
2) run 'redhat-config-xfree86'
3) See if you can select "1024x768".  If not, go to step 4
4) click on the "Hardware" tab and see if the correct monitor was probed.  If
not, select the right monitor.
5) Go back to the "Settings" tab and see if you can select "1024x768" now.
Comment 4 Rainer Traut 2003-10-16 03:44:08 EDT
Ok, think there is still sth. wrong:
here's the steps I did

1) delete /etc/X11/XF86Config (or move out of the way)
ok

2) run 'redhat-config-xfree86'
first ddcprobe: bogus results
tries to start i845: fails
second ddcprobe: bogus results
starts with permedia2

3) See if you can select "1024x768".  If not, go to step 4
no i cannot select 1024*768

4) click on the "Hardware" tab and see if the correct monitor was probed.  If
not, select the right monitor.
I must select a similar monitor: adi microscan 5v+
mine is Sun CHB7727L

5) Go back to the "Settings" tab and see if you can select "1024x768" now.
yes now I can
select millions of colors (probably wrong? card cannot do this?)
select OK

after that I startx, get 800*600 85hz ! (first problem?)

quit X, start redhat-config-xfree

now I select 1024*768, thousands of colors, OK, startx

I get again 800*600 85hz (second problem?)

quit X, delete XF86config. start redhat-config-xfree

select monitor, 1024*768, thousands of colors(difference!), OK, startx

Now it's ok 1024*768

Hope it's not to confusing, what I have written! :)
Comment 5 Brent Fox 2003-10-16 15:20:28 EDT
Ah, ok.  I think I might see the problem.  I think that the ADI MicroScan 5V+
monitor that you are manually selecting is quite different from your actual Sun
monitor.  

From documentation I've found on the web, it looks like your Sun monitor is made
by Samsung and has different refresh rates than the ADI.

For example, according to our monitor database, the ADI 5V+ has a horizontal
refresh rate of (30.0-64.0) kHz and a vertical refresh of (50.0-100.0) Hz. 
According to
http://sunsolve.sun.com/handbook_pub/Devices/Monitor/MONITOR_Color_17_Entry_CRT.html#365-1396
the Sun monitor has refresh rates of (30.0-72.0) kHz and (50.0-160.0) Hz.

As you can see, the Sun monitor is capable of higher refresh rates than you were
setting it to.  The closest thing in our monitor list is the "Samsung SyncMaster
710(M)b (CHB7709*)".  Try selecting that monitor and see if the problem doesn't
go away.  You should be able to use 1024x768 no problem with that monitor.

Just for completeness, I've added an entry to our monitor database for this
monitor as "Sun 17-inch CHB7727L (Samsung)" with the correct refresh rates,
which should appear in hwdata-0.100-1.
Comment 6 Jay Turner 2004-01-16 11:51:27 EST
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2004-014.html

Note You need to log in before you can comment on or make changes to this bug.