Bug 1071536 - Notifier doesn't send any notifications via email
Summary: Notifier doesn't send any notifications via email
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-notificiations
Version: 3.4
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 3.4.0
Assignee: Martin Perina
QA Contact: Jiri Belka
URL:
Whiteboard: infra
Depends On:
Blocks: 1024889 1051093 1051492
TreeView+ depends on / blocked
 
Reported: 2014-03-01 12:59 UTC by Martin Perina
Modified: 2014-03-31 12:29 UTC (History)
6 users (show)

Fixed In Version: ovirt-3.4.0-ga
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-31 12:29:59 UTC
oVirt Team: ---


Attachments (Terms of Use)
logs (684.59 KB, application/gzip)
2014-03-01 12:59 UTC, Martin Perina
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 25204 0 None MERGED tools: Match transport names with EventNotificationMethod Never
oVirt gerrit 25205 0 None MERGED tools: Match transport names with EventNotificationMethod Never
oVirt gerrit 25282 0 None MERGED tools: Fix clearing event filters in notifier Never
oVirt gerrit 25292 0 None MERGED tools: Fix clearing event filters in notifier Never
oVirt gerrit 25313 0 None MERGED tools: Match transport names with EventNotificationMethod Never
oVirt gerrit 25314 0 None MERGED tools: Fix clearing event filters in notifier Never

Description Martin Perina 2014-03-01 12:59:20 UTC
Created attachment 869329 [details]
logs

Description of problem:

No notifications are send via email through notifier even when configured correctly. If you set DEBUG priority to notifier log, there are these errors in notifier.log:

2014-03-01 13:47:56,308 DEBUG [org.ovirt.engine.core.notifier.filter.FirstMatchSimpleFilter] Recipient: Recipient{transport='EMAIL', name='mperina@redhat.com'}
2014-03-01 13:47:56,309 DEBUG [org.ovirt.engine.core.notifier.filter.FirstMatchSimpleFilter] Entry match((include)): FilterEntry{eventName='VDS_DETECTED', exclude=false, recipient=Recipient{transport='EMAIL', name='mperina@redhat.com'}}
2014-03-01 13:47:56,309 DEBUG [org.ovirt.engine.core.notifier.filter.FirstMatchSimpleFilter] Ignoring recipient 'Recipient{transport='EMAIL', name='mperina@redhat.com'}' as transport not registered

Version-Release number of selected component (if applicable):

3.4.0-0.12.master.20140228075627

How reproducible:

100% 
Steps to Reproduce:
1. Assign all 'General Host Events' notifications for user

2. Configure notifier in /etc/ovirt-engine/notifier/notifier.conf.d/99-user.conf with:
    MAIL_SERVER=smtp.corp.redhat.com
    MAIL_FROM=mperina@redhat.com
    FILTER="include:*(smtp:*)"

3. Start notifier daemon and set host status to Maintenance

Actual results:

No notifications are sent

Expected results:

Notifications are sent

Additional info:

Comment 1 Martin Perina 2014-03-01 13:30:46 UTC
Without fixing this, notifier is completely unuseable in oVirt 3.4. So I suggest this one as a blocker.

Comment 2 Mooli Tayer 2014-03-03 16:19:43 UTC
p.s There is no need to define a subscriber in both configuration and db.

In this case there is a bug in database and in the configuration it should be:
FILTER="include:*(smtp:mperina@redhat.com)"
instead of
FILTER="include:*(smtp:*)"

I such a case the above notification(VDS_DETECTED) will be sent twice once the bug is fixed

Comment 3 Martin Perina 2014-03-12 13:31:12 UTC
Included in oVirt 3.4 RC2

Comment 4 Jiri Belka 2014-03-18 14:31:04 UTC
This needs av4 or newer.

Comment 5 Jiri Belka 2014-03-21 08:43:47 UTC
ok, av4.

Comment 6 Martin Perina 2014-03-21 13:13:34 UTC
The patch is also included in av3.1 and sending email with notifier worked fine for me in that version

Comment 7 Sandro Bonazzola 2014-03-31 12:29:59 UTC
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released


Note You need to log in before you can comment on or make changes to this bug.