Bug 1071552 - [abrt] nf3d: nf3d:23:<module>:ImportError: No module named pg
Summary: [abrt] nf3d: nf3d:23:<module>:ImportError: No module named pg
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: nf3d
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Christopher Meng
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:60891b690428a6ca031f9182b3a...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-01 16:19 UTC by ssabchew
Modified: 2014-03-19 20:20 UTC (History)
3 users (show)

Fixed In Version: nf3d-0.8-2.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-15 15:10:30 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (1.14 KB, text/plain)
2014-03-01 16:19 UTC, ssabchew
no flags Details
File: environ (2.46 KB, text/plain)
2014-03-01 16:19 UTC, ssabchew
no flags Details

Description ssabchew 2014-03-01 16:19:47 UTC
Version-Release number of selected component:
nf3d-0.8-1.fc20

Additional info:
reporter:       libreport-2.1.12
cmdline:        /usr/bin/python2 /bin/nf3d -D 3600
executable:     /bin/nf3d
kernel:         3.13.3-201.fc20.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
nf3d:23:<module>:ImportError: No module named pg

Traceback (most recent call last):
  File "/bin/nf3d", line 23, in <module>
    import pg
ImportError: No module named pg

Local variables in innermost frame:
__builtins__: <module '__builtin__' (built-in)>
__file__: '/bin/nf3d'
__package__: None
sys: <module 'sys' (built-in)>
getopt: <module 'getopt' from '/usr/lib64/python2.7/getopt.pyc'>
__name__: '__main__'
os: <module 'os' from '/usr/lib64/python2.7/os.pyc'>
__doc__: '\nCopyright(C) 2008,2013 Eric Leblond\n\nThis program is free software; you can redistribute it and/or modify\nit under the terms of the GNU General Public License as published by\nthe Free Software Foundation, version 3 of the License.\n\nThis program is distributed in the hope that it will be useful,\nbut WITHOUT ANY WARRANTY; without even the implied warranty of\nMERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the\nGNU General Public License for more details.\n\nYou should have received a copy of the GNU General Public License\nalong with this program; if not, write to the Free Software\nFoundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.\n'

Comment 1 ssabchew 2014-03-01 16:19:53 UTC
Created attachment 869410 [details]
File: backtrace

Comment 2 ssabchew 2014-03-01 16:19:56 UTC
Created attachment 869411 [details]
File: environ

Comment 3 Christopher Meng 2014-03-03 05:12:39 UTC
I feel so sorry for this package! This package was approved too quickly.

I will fix them soon.

Comment 4 Fedora Update System 2014-03-04 01:22:25 UTC
nf3d-0.8-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/nf3d-0.8-2.el6

Comment 5 Fedora Update System 2014-03-04 01:22:37 UTC
nf3d-0.8-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/nf3d-0.8-2.fc19

Comment 6 Fedora Update System 2014-03-04 01:22:45 UTC
nf3d-0.8-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/nf3d-0.8-2.fc20

Comment 7 lnie 2014-03-04 04:05:41 UTC
nf3d-0.8-2.fc20 still crash ,see bug #1072138 for details

Comment 8 Fedora Update System 2014-03-04 19:31:41 UTC
Package nf3d-0.8-2.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing nf3d-0.8-2.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-0740/nf3d-0.8-2.el6
then log in and leave karma (feedback).

Comment 9 Stiliyan Sabchew 2014-03-06 07:21:42 UTC
yum update --enablerepo=epel-testing nf3d-0.8-2.el6

...

Error: Package: nf3d-0.8-2.el6.noarch (epel-testing)
           Requires: python-visual
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

There is no python-visual in EPEL repo:(
Actually it will be OK for Fedora, where I test it initially.

Comment 10 Christopher Meng 2014-03-06 09:49:17 UTC
(In reply to Stiliyan Sabchew from comment #9)
> yum update --enablerepo=epel-testing nf3d-0.8-2.el6
> 
> ...
> 
> Error: Package: nf3d-0.8-2.el6.noarch (epel-testing)
>            Requires: python-visual
>  You could try using --skip-broken to work around the problem
>  You could try running: rpm -Va --nofiles --nodigest
> 
> There is no python-visual in EPEL repo:(
> Actually it will be OK for Fedora, where I test it initially.

Yes, EPEL never has visual packaged.

I've sent email to Fedora owner, please wait.

Comment 11 Fedora Update System 2014-03-15 15:10:30 UTC
nf3d-0.8-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2014-03-15 15:24:03 UTC
nf3d-0.8-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2014-03-19 20:20:43 UTC
nf3d-0.8-2.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.