Bug 107164 - Loki installer cant make gnome-menu entry
Loki installer cant make gnome-menu entry
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: redhat-menus (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-15 12:07 EDT by Bjorn Ryborg
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: RHEL 4 / FC 4
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-09 15:04:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bjorn Ryborg 2003-10-15 12:07:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; da-DK; rv:1.5) Gecko/20030927

Description of problem:
After installing a never game who uses the loki installer, it does not make an
entry in the gnome-menu. It happen with the Enemy Teritory and Americas Army
games. (and more, ex. Gtk-radiant)

The Loki installer makes this file:
/etc/X11/applnk/Games/et.desktop

It looks like this:

[Desktop Entry]
Encoding=UTF-8
Name=enemy-territory
Comment=
Exec=/usr/local/games/enemy-territory/et
Icon=/usr/local/games/enemy-territory/ET.xpm
Terminal=0
Type=Application
Categories=Application;Games;X-Red-Hat-Base;



To correct the problem, i have to delete the line:

Categories=Application;Games;X-Red-Hat-Base;

and the icon shows properly in the Games menu in the Gnome-start menu.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. download the enemy teritory (et) game from ftp.idsoftware.com
2.install the game
3.Restart X and look in the start-menu.
    

Actual Results:  No entry in the Gnome-start menu

Expected Results:  An icon and entry for the game in the Gnome-menu.

Additional info: I have mailed several times to ID Software, and the developer
of GTK Radiant, but they all say it is a RedHat-Gnome  bug.
Comment 1 Bjorn Ryborg 2003-11-11 12:06:36 EST
In final Fedora Core it does not help to delete the line;
Categories=Application;Games;X-Red-Hat-Base;

It is not possible to get an menu entry for these games (Enemy
Teritory and Americas Army and others) Fedora is no longer kompatible
with the loki installer...
Comment 2 Mark McLoughlin 2004-02-20 09:31:20 EST
Moving to redhat-menus. More than likely a problem with the
applications vfolder.

Try playing with /etc/X11/desktop-menus/applications.menu and let us
know if you have any success. Thanks.
Comment 3 Ray Strode [halfline] 2005-09-09 15:04:44 EDT
Hi Bjorn,

Red Hat doesn't currently have the resources to devote toward resolving this
issue.  If you figure out a solution, we'll be happy review it and apply it, of
course.
Comment 4 Bjorn Ryborg 2005-09-10 00:04:31 EDT
The problem has solved itself, somehow. It works in Fedora 4 and RHEL4.
Comment 5 Ray Strode [halfline] 2005-09-12 10:09:03 EDT
Hi Bjorn,

That's good to hear.  I'll change the status appropriately.

Note You need to log in before you can comment on or make changes to this bug.