Bug 107171 - Installer crashes at X-server start-up
Installer crashes at X-server start-up
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
rawhide
athlon Linux
low Severity low
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-15 13:13 EDT by Richard Ayer III
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-01 02:37:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XF86Config File (3.08 KB, text/plain)
2003-10-27 19:49 EST, Albert Sidelnik
no flags Details

  None (edit)
Description Richard Ayer III 2003-10-15 13:13:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 
1.1.4322)

Description of problem:
After doing the media check (where all 3 install discs passed), anaconda 
starts and opens the X-server to do the graphical install/upgrade. A blank 
white screen and the mouse cursor (unmovable) are displayed. The system hangs 
there and seems to be trying to access the floppy drive (light is on). Nothing 
happens beyond that point; must use reset button on case to reboot, CTRL-ALT-
DEL does not work. I have both RH9 and Fedora Test 2 installed on the same 
machine and did not have this problem.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Choose graphical install/upgrade from initial boot menu
2.
3.
    

Actual Results:  Cannot install or upgrade to Fedora Test3.

Expected Results:  Expected to be able to.

Additional info:
Comment 1 Jeremy Katz 2003-10-15 14:15:22 EDT
What type of hardware (machine and video card)?  Do the keyboard lights blink
when it hangs?
Comment 2 Richard Ayer III 2003-10-15 15:01:34 EDT
Self-built machine:
   Athlon XP 1800+
   All-In-Wonder Radeon 9800
   Sylvania F70 17" CRT
   Logitech Cordless Freedom Pro (doesn't have lights)
   WD1200JB
   WD2000JB (on controller card, can look up brand etc. tonight if needed)
Comment 3 Jeremy Katz 2003-10-15 19:04:45 EDT
I've seen another report of problems (including post-install) on a 9800
Comment 4 Albert Sidelnik 2003-10-27 19:49:34 EST
Created attachment 95537 [details]
XF86Config File

I am using a Radeon 9800 120Mb and Viewsonic VP171b monitor.
Comment 5 Albert Sidelnik 2003-10-27 19:51:30 EST
I just upgraded from Rh9 to Fedore Test via rpm updates (not the regular
install), and everything was working well, until I upgraded to the latest
XFree86 packages (4.3.0-42). Now when X starts it hangs after a few seconds and
causes my machine to lock up completely, forcing me to do a cold reboot. I also
tried to boot into anaconda with the fedora cds, and it also hangs on a white
screen. I have a feeling this is somewhat related to the problem due to this
bug. Btw., I am able to start if I have the default vesa driver (generic)
settings in my XF86Config file.
Comment 6 Harald Glatt 2003-11-04 17:51:20 EST
Hi there,

I was just going to file in a bug for this when I found this bug...
I have the same problem! I am using a TFT with native 1280x1024
Resolution...

When I start the CD1 with "linux" the PC seems to freeze when it
starts up X just like the reporter...
When I start the CD1 with "linux resolution=1280x1024" X starts
correctly... But when I press on the "Next" button on the first
language selection menu the whole pc freezes again...

I therefore installed Fedora with the text setup... When it`s starting
the Graphical Boot XFree it crashes again...
So I was booting with kernel parameter "3 nogb" to disable the
graphical boot... Once I did this I was able to log into the system...

I opened /etc/X11/XF86Config and changed the driver "radeon" in the
device section of my graphics card to driver "vesa" which is not
capable of 24bit colors to solve the crashing. It did work!

X runs good for me now, but its no good solution since I cannot use
24bit color, nor do I have any hardware acceleration...

I have the following PC:

Athlon XP 2600+
1.5 GB Ram
2x 120 GB HDD (SATA siimage)
ATI Radeon 9800 Pro (detected as non-pro by the setup)
17" TFT with 1280x1024 native resolution
NForce2 based Motherboard (ASUS A7N8X)

Concluding from the other posts and stuff I`ve read so far I`d think
it has definitly to do with the radeon driver and only seems to affect
Radeon 9800 users(?).

Please fix this! This should be a blocker bug or something similar
because ALL people using a Radeon 9800 or perhaps also 9700 are
affected and CANNOT install nor boot Fedora.


I used up2date to update my whole system to current stuff... The
problem is still there when enabling the radeon driver in XF86Config...
Comment 7 Mike A. Harris 2003-11-04 19:42:07 EST
Just to be 100% perfectly clear here, Radeon 9800/9600 support
is EXPERIMENTAL.  This support is NOT official and not part of
XFree86 4.3.0.  I personally did this work on my own personal
time voluntarily, and added it experimentally to the distribution
in order to both test it, and so that people could use it if
it worked for them.

>Please fix this! This should be a blocker bug or something similar
>because ALL people using a Radeon 9800 or perhaps also 9700 are
>affected and CANNOT install nor boot Fedora.

Fedora Core 1 is officially done.  Zero more bugs are getting fixed,
and the CD images are being finalized for the final official public
release sometime in the next few days or so.  This is definitely
NOT a blocker bug, because this hardware is not officially supported
by XFree86 4.3.0 anyway.

So there are two options here:

1) People who have problems are encouraged to POLITELY report them
   to me, via bugzilla, and when I have personal spare time on a
   weekend or somesuch I will investigate the problem and hopefully
   be able to reproduce it and fix it.

or

2) People can be rude and demanding, and I can just remove Radeon
   9800 support entirely and everyone can wait 6-8 months for
   Fedora Core 2 which will probably come with XFree86 4.4.0.


I really don't like rude and demanding bug reports.  Especially
when it is concerning code I work on voluntarily in my spare
time.  If this is a problem for Fedora users, then I will just
ship XFree86 in the future with the hardware it supports by default
and no extra backported or volunteer driven driver development or
patches in it.  I will then supply experimental drivers off my
personal non-Red Hat web page, to make it clear that it is not
Red Hat officially supported work.



Comment 8 Harald Glatt 2003-11-04 20:15:28 EST
I am a user who tried Fedora as a distribution today and who had only
problems with it because of those crashes. I was asking for help in
#Fedora on freenode and the guys there told me to file a bug since
this seems to be a bug... 
That's what I did. Just because I was begging for a solution I see no
reason why you call me "rude" or "demanding".
A user like me can`t have the knowledge that XFree 4.3.0 doesn`t
support  this hardware, I also cannot know that YOU did extra work to
implement it...
Fedora is a project to work with the community. That's what I did. As
part of it I tried to make this bug report as clear as possible so you
can find a solution.

To be honest I rather find your answer rude than my previous post...

I`m sorry to made you an additional burden through this bug... But
that's the communitys job. And I think I made some pretty good work
tracking this bug to the source... A normal user would have cried "it
doesn't work" and noone would even have heared what the thing was that
didn't work...

I don`t want you to remove the work you did from Fedora again but I
hope that you don`t take bug reports as an insult in future... It
surely wasn`t meant as that... I have no idea who is writing what
driver for what part of the system... 

However as you yourself said... It is not clear to a normal user that
this isn`t Red Hat officially supported work. However the installer is
crashing everyone with a Radeon 9800 currently. Also if your driver
was written in your spare time and XFree doesn`t support the 9800
nativly there should be a solution for this problem until your driver
is working without crashes! For example the installer could use vesa
as XFree driver for all ATI Radeon 9800 cards instead of radeon...

I hope you don`t take this second post as an offence too. It`s not
meant as such.
Comment 9 Richard Ayer III 2003-11-05 12:08:35 EST
Mike,
   Let me just say that I do appreciate any work you can do/have 
done to get things working with the 9800's. Just for clarification 
let me ask this: Does your most recent post mean that a graphical 
install of the Fedora 1 release will not be possible when using a 
9800?

Thanks,
Richard Ayer III
Comment 10 Mike A. Harris 2004-10-01 02:37:21 EDT
Since this bugzilla report was filed, there have been several major
updates to the X Window System, which may resolve this issue.  Users
who have experienced this problem are encouraged to upgrade to the
latest version of Fedora Core, which can be obtained from:

If this issue turns out to still be reproduceable in the latest
version of Fedora Core, please file a bug report in the X.Org
bugzilla located at http://bugs.freedesktop.org in the "xorg"
component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.

Note You need to log in before you can comment on or make changes to this bug.