Bug 1071740
| Summary: | RHEV: Cannot start VMs that have more than 23 snapshots. | ||
|---|---|---|---|
| Product: | Red Hat Enterprise Linux 6 | Reporter: | Jan Kurik <jkurik> |
| Component: | qemu-kvm | Assignee: | Jeff Cody <jcody> |
| Status: | CLOSED ERRATA | QA Contact: | Virtualization Bugs <virt-bugs> |
| Severity: | urgent | Docs Contact: | |
| Priority: | urgent | ||
| Version: | 6.5 | CC: | acathrow, areis, bazulay, bsarathy, chayang, famz, fsimonce, gwatson, iheim, jcody, jherrman, juzhang, knoel, kwolf, lpeer, michen, mkalinin, mkenneth, mrezanin, pbonzini, pm-eus, qzhang, sgordon, shu, tlavigne, virt-maint, yeylon |
| Target Milestone: | rc | Keywords: | ZStream |
| Target Release: | --- | ||
| Hardware: | x86_64 | ||
| OS: | Linux | ||
| Whiteboard: | |||
| Fixed In Version: | qemu-kvm-0.12.1.2-2.415.el6_5.6 | Doc Type: | Bug Fix |
| Doc Text: |
Previously, the number of characters in the file name strings for virtual machine (VM) images was limited. Because repeated creation of VM image snapshots gradually increases the file name string size, this eventually resulted in either of the following problems when the size limit was reached: creating an image snapshot failed to be executed or the VM did not successfully boot. This update fixes the handling of file names so that long file names are now supported, and the mentioned problems no longer occur.
|
Story Points: | --- |
| Clone Of: | Environment: | ||
| Last Closed: | 2014-03-17 12:15:52 UTC | Type: | --- |
| Regression: | --- | Mount Type: | --- |
| Documentation: | --- | CRM: | |
| Verified Versions: | Category: | --- | |
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |
| Cloudforms Team: | --- | Target Upstream Version: | |
| Embargoed: | |||
| Bug Depends On: | 1067576, 1072339, 1113583 | ||
| Bug Blocks: | |||
|
Description
Jan Kurik
2014-03-03 05:33:33 UTC
Fix included in qemu-kvm-0.12.1.2-2.415.el6_5.6 Reproduced on qemu-kvm-rhev-0.12.1.2-2.415.el6_5.5.x86_64: run test script from: https://bugzilla.redhat.com/show_bug.cgi?id=1067576#c28 [root@ibm-x3650m3-04 ~]# ./test.sh Formatting 'base.qcow2', fmt=qcow2 size=1073741824 encryption=off cluster_size=65536 Performing live snapshot test ----------------------------- Waiting to connect to qmp socket... ./test.sh: connect: Connection refused ./test.sh: line 44: /dev/tcp/localhost/44444: Connection refused connected! snapshot-0: success! snapshot-1: success! snapshot-2: success! snapshot-3: success! snapshot-4: success! snapshot-5: success! ... snapshot-25: failed! (see this-is-a-test-dir-for-snapshots-2844/output.log) snapshot-26: failed! (see this-is-a-test-dir-for-snapshots-2844/output.log) snapshot-27: failed! (see this-is-a-test-dir-for-snapshots-2844/output.log) snapshot-28: failed! (see this-is-a-test-dir-for-snapshots-2844/output.log) ... snapshot-79: failed! (see this-is-a-test-dir-for-snapshots-2844/output.log) Performing qemu-img snapshot test --------------------------------- snapshot-0: success! snapshot-1: success! snapshot-2: success! snapshot-3: success! snapshot-4: success! ... snapshot-24: success! snapshot-25: failed! (see this-is-a-test-dir-for-snapshots-2844/output.log) snapshot-26: failed! (see this-is-a-test-dir-for-snapshots-2844/output.log) snapshot-27: failed! (see this-is-a-test-dir-for-snapshots-2844/output.log) snapshot-28: failed! (see this-is-a-test-dir-for-snapshots-2844/output.log) ... snapshot-79: failed! (see this-is-a-test-dir-for-snapshots-2844/output.log) Killing qemu process (2848).... done, left directory this-is-a-test-dir-for-snapshots-2844 intact Verified on qemu-kvm-rhev-0.12.1.2-2.415.el6_5.6.x86_64: run same script, all 80 snapshots success with both qemu-kvm and qemu-img. Test with qemu-kvm-0.12.1.2-2.415.el6_5.6.x86_64: [root@ibm-x3650m3-04 ~]# ./test.sh Formatting 'base.qcow2', fmt=qcow2 size=1073741824 encryption=off cluster_size=65536 Performing qemu-img snapshot test --------------------------------- snapshot-0: success! snapshot-1: success! snapshot-2: success! snapshot-3: success! snapshot-4: success! snapshot-5: success! ... snapshot-77: success! snapshot-78: success! snapshot-79: success! Killing qemu process (3634).... done, left directory this-is-a-test-dir-for-snapshots-3630 intact Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. For information on the advisory, and where to find the updated files, follow the link below. If the solution does not work for you, open a new bug report. http://rhn.redhat.com/errata/RHBA-2014-0302.html |