Bug 1071855 - fails to build for EPEL branches
Summary: fails to build for EPEL branches
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: python-requests-oauthlib
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ralph Bean
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-03 10:24 UTC by Jakub Dorňák
Modified: 2016-12-01 00:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-05-06 00:34:38 UTC
Type: Bug


Attachments (Terms of Use)
git commit solving this issue (1.57 KB, patch)
2014-03-03 10:24 UTC, Jakub Dorňák
no flags Details | Diff

Description Jakub Dorňák 2014-03-03 10:24:43 UTC
Created attachment 869877 [details]
git commit solving this issue

Description of problem:
Python3 and python version related macros required to build python3- subpackage are not available in el6 and el7

Version-Release number of selected component (if applicable):
0.4.0-3.el7

Additional info:
patch attached

Comment 1 Ralph Bean 2014-03-07 14:40:03 UTC
I got it built for epel7.

There are issues with el6, though.  python-requests-oauthlib depends on python-oauthlib, and python-oauthlib is having hard time being built for el6.

See: http://koji.fedoraproject.org/koji/taskinfo?taskID=6609362

Looks like it is expecting to use some stuff from the stdlib that doesn't exist for py2.6.

Comment 2 Ralph Bean 2014-03-11 12:14:46 UTC
Ah, this might be a solution to that problem:  https://bugzilla.redhat.com/show_bug.cgi?id=1074916

Comment 3 Ralph Bean 2014-04-17 17:15:31 UTC
Finally built python-oauthlib for el6 -> http://koji.fedoraproject.org/koji/taskinfo?taskID=6750352

Buildroot override submitted.

Comment 4 Fedora Update System 2014-04-17 17:39:45 UTC
python-requests-oauthlib-0.4.0-4.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/python-requests-oauthlib-0.4.0-4.el6

Comment 5 Fedora Update System 2014-05-06 00:01:45 UTC
python-requests-oauthlib-0.4.0-4.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.