Bug 107186 - Idle percentage in top sometimes gets very large
Summary: Idle percentage in top sometimes gets very large
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: procps   
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-15 18:20 UTC by Forrest
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-13 23:55:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen shot of gnome-terminal when this happens (28.87 KB, image/jpeg)
2003-10-15 18:28 UTC, Forrest
no flags Details

Description Forrest 2003-10-15 18:20:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031009

Description of problem:
When running a dual-processor under load, top sometimes reports bogus numbers. 
This appears to happen when the percentages all add up to 100% or more:

cpu00   13.4%  85.4%  1.3%  0.0%  0.0% 0.0%  3638411059903264.4%

Version-Release number of selected component (if applicable):
procps-2.0.17-1

How reproducible:
Sometimes

Steps to Reproduce:
1.  Put the system under load (the easiest for me is to run two instances of
setiathome)
2.  Watch top for a while

Actual Results:  Percent Idle jumps from 0 to a very large number

Expected Results:  Percent Idle stays a 0

Comment 1 Forrest 2003-10-15 18:28:10 UTC
Created attachment 95208 [details]
Screen shot of gnome-terminal when this happens

Comment 2 Alexander Larsson 2003-10-16 08:08:47 UTC
Ugh. Probably related to the iowait patch.

Comment 3 Alexander Larsson 2004-02-05 10:31:04 UTC
Mass reassign to the new owner

Comment 4 Forrest 2004-02-13 23:55:26 UTC
Seems to be fixed on Fedora Core 2 Test 1, so I'll close it, and
reopen this if it crops up again.


Note You need to log in before you can comment on or make changes to this bug.