Bug 1071914 - Regression: Kernel update made Brainboxes ExpressCard device stop working
Summary: Regression: Kernel update made Brainboxes ExpressCard device stop working
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 19
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-03 12:57 UTC by Troels Arvin
Modified: 2014-05-06 03:30 UTC (History)
7 users (show)

Fixed In Version: kernel-3.13.11-100.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-05-01 22:31:24 UTC
Type: Bug


Attachments (Terms of Use)
udev rules file (5.12 KB, text/plain)
2014-03-03 12:57 UTC, Troels Arvin
no flags Details
Output from "modinfo ftdi_sio" with an older F19 kernel (38.21 KB, text/plain)
2014-03-03 12:58 UTC, Troels Arvin
no flags Details
Output from "modinfo ftdi_sio" with a newer F19 kernel (39.66 KB, text/plain)
2014-03-03 12:59 UTC, Troels Arvin
no flags Details
Output from "lsusb -v" with an older F19 kernel (77.97 KB, text/plain)
2014-03-03 13:01 UTC, Troels Arvin
no flags Details
Output from "lsusb -v" with a newer F19 kernel (77.97 KB, text/plain)
2014-03-03 13:01 UTC, Troels Arvin
no flags Details

Description Troels Arvin 2014-03-03 12:57:24 UTC
Created attachment 869923 [details]
udev rules file

A kernel update for F19 around New Year made my Brainboxes VX-001 RS232 ExpressCard stop working.

I believe that things worked up to generation 3.9 of the Fedora 19 kernel (could also be 3.10). Reverting to the old kernel-3.9.5-301.fc19.x86_64 package (shipped with F19) makes things work again. I can't find the older kernel updates for F19, so I can't pinpoint exactly when it went wrong.

Attached 99-bbftdisio.rules file exists in /etc/udev/rules.d/
This used to mean that when the ExpressCard was inserted in my Lenovo laptop, the following message would appear in /var/log/messages:

Mar  3 12:10:08 hostname kernel: [  163.419818] usb 2-1.6: new full-speed USB device number 4 using ehci-pci
Mar  3 12:10:08 hostname kernel: [  163.514104] usb 2-1.6: New USB device found, idVendor=05d1, idProduct=1001
Mar  3 12:10:08 hostname kernel: [  163.514113] usb 2-1.6: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Mar  3 12:10:08 hostname kernel: [  163.514117] usb 2-1.6: Product: ExpressCard 1 Port RS232 (U)
Mar  3 12:10:08 hostname kernel: [  163.514121] usb 2-1.6: Manufacturer: Brainboxes
Mar  3 12:10:08 hostname kernel: [  163.514124] usb 2-1.6: SerialNumber: VXFTQ0E0
Mar  3 12:10:08 hostname kernel: [  163.518301] ftdi_sio 2-1.6:1.0: FTDI USB Serial Device converter detected
Mar  3 12:10:08 hostname kernel: [  163.518351] usb 2-1.6: Detected FT232RL
Mar  3 12:10:08 hostname kernel: [  163.518355] usb 2-1.6: Number of endpoints 2
Mar  3 12:10:08 hostname kernel: [  163.518359] usb 2-1.6: Endpoint 1 MaxPacketSize 64
Mar  3 12:10:08 hostname kernel: [  163.518363] usb 2-1.6: Endpoint 2 MaxPacketSize 64
Mar  3 12:10:08 hostname kernel: [  163.518366] usb 2-1.6: Setting MaxPacketSize 64
Mar  3 12:10:08 hostname kernel: [  163.518736] usb 2-1.6: FTDI USB Serial Device converter now attached to ttyUSB0
Mar  3 12:10:08 hostname mtp-probe: checking bus 2, device 4: "/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.6"
Mar  3 12:10:08 hostname mtp-probe: bus: 2, device: 4 was not an MTP device

After this, a new device would show up in /dev:
crw-rw----  1 root dialout   188,   0 Mar  3 12:10 ttyUSB0

With the newer kernel packages, the following happens when the device is inserted:
Mar  3 12:22:41 hostname kernel: [  163.124979] usb 2-1.6: new full-speed USB device number 3 using ehci-pci
Mar  3 12:22:41 hostname kernel: [  163.219506] usb 2-1.6: New USB device found, idVendor=05d1, idProduct=1001
Mar  3 12:22:41 hostname kernel: [  163.219517] usb 2-1.6: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Mar  3 12:22:41 hostname kernel: [  163.219523] usb 2-1.6: Product: ExpressCard 1 Port RS232 (U)
Mar  3 12:22:41 hostname kernel: [  163.219527] usb 2-1.6: Manufacturer: Brainboxes
Mar  3 12:22:41 hostname kernel: [  163.219531] usb 2-1.6: SerialNumber: VXFTQ0E0
Mar  3 12:22:41 hostname mtp-probe: checking bus 2, device 3: "/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.6"
Mar  3 12:22:41 hostname mtp-probe: bus: 2, device: 3 was not an MTP device 
Mar  3 12:22:41 hostname kernel: [  163.285249] ftdi_sio: unknown parameter 'product' ignored
Mar  3 12:22:41 hostname kernel: [  163.285253] ftdi_sio: unknown parameter 'vendor' ignored
Mar  3 12:22:41 hostname kernel: [  163.285451] usbcore: registered new interface driver ftdi_sio
Mar  3 12:22:41 hostname kernel: [  163.285478] usbserial: USB Serial support registered for FTDI USB Serial Device

- but no /dev/ttyUSB0 shows up in /dev

The ftdi_sio kernel module _is_ loaded by the newer kernel, like it was before:
# lsmod | fgrep ftdi_sio
ftdi_sio               48930  0

Comment 1 Troels Arvin 2014-03-03 12:58:47 UTC
Created attachment 869925 [details]
Output from "modinfo ftdi_sio" with an older F19 kernel

Comment 2 Troels Arvin 2014-03-03 12:59:28 UTC
Created attachment 869926 [details]
Output from "modinfo ftdi_sio" with a newer F19 kernel

Comment 3 Troels Arvin 2014-03-03 13:01:13 UTC
Created attachment 869927 [details]
Output from "lsusb -v" with an older F19 kernel

Comment 4 Troels Arvin 2014-03-03 13:01:48 UTC
Created attachment 869928 [details]
Output from "lsusb -v" with a newer F19 kernel

Comment 5 Troels Arvin 2014-03-04 10:39:15 UTC
The procedure at http://www.brainboxes.com/faq/items/where-can-i-find-the-latest-linux-drivers-for-my-usb-device-or-e makes the device work again, but init scripts are not a good fit for Fedora, going forward. And it doesn't explain why something which used to work stops working with a newer kernel for the same Fedora generation.

Comment 6 Justin M. Forbes 2014-03-10 14:47:00 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.13.5-100.fc19.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.

Comment 7 Troels Arvin 2014-03-11 09:21:42 UTC
With 3.13.5-103.fc19.x86_64, the problem is still there. Do I really need to open a new case about this?

Comment 8 Michele Baldessari 2014-03-17 20:04:52 UTC
Hi Troels,

no need to open a new BZ, no. If you do a:
echo 05d1 1001  >/sys/bus/usb-serial/drivers/ftdi_sio/new_id

Does it work?

thanks,
Michele

Comment 9 Troels Arvin 2014-03-25 12:35:45 UTC
With 3.13.6-100.fc19.x86_64: When inserting the card, the /dev/ttyUSB0 device is still not automatically created, like it was with some of the earlier FC19 kernels.

"echo 05d1 1001  >/sys/bus/usb-serial/drivers/ftdi_sio/new_id" makes the device appear, however. Still, I believe this is a regression: Something used to work with an earlier kernel in FC19, but now it doesn't work any longer unless some special trick is used.

Comment 10 Michele Baldessari 2014-03-25 18:07:50 UTC
Agreed. I just needed confirmation that the echo command worked. I'll send the updated VID/PID upstream. 

I'll keep you posted here

Comment 11 Troels Arvin 2014-03-28 13:14:06 UTC
The problem still exists in the newly released 3.13.7-100.fc19.x86_64 package, but the "echo 05d1 1001  >/sys/bus/usb-serial/drivers/ftdi_sio/new_id" still works.

From tomorrow, I will no longer have access to the hardware, so I will not be able to follow this bug. Feel free to close it, due to this.

Comment 12 Michele Baldessari 2014-03-31 10:49:20 UTC
Usb serial maintainer will commit the updated PID/VID table for Brainboxes devices.

Troels, thanks for reporting. I guess if none else is asking for this
we can wait for whenever it will trickle down from upstream

Comment 13 Michele Baldessari 2014-04-19 09:36:10 UTC
This has hit Linus tree now:
commit efe26e16b1d93ac0085e69178cc18811629e8fc5
Author: Michele Baldessari <michele@acksyn.org>
Date:   Mon Mar 31 10:51:00 2014 +0200

    USB: serial: ftdi_sio: add id for Brainboxes serial cards


It was CC'ed to stable@ as well. Setting to POST (Josh, I hope this is correct.
Feel free to clue me in if that's not the right status)

Comment 14 Josh Boyer 2014-04-21 14:00:47 UTC
Yep, that's just fine.  I'll grab it today.

Comment 15 Josh Boyer 2014-04-21 15:14:04 UTC
Picked up in Fedora git.  Thanks again Michele!

Comment 16 Fedora Update System 2014-04-22 02:44:08 UTC
kernel-3.14.1-200.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/kernel-3.14.1-200.fc20

Comment 17 Fedora Update System 2014-04-23 04:34:33 UTC
Package kernel-3.14.1-200.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.14.1-200.fc20'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-5502/kernel-3.14.1-200.fc20
then log in and leave karma (feedback).

Comment 18 Fedora Update System 2014-04-24 18:15:46 UTC
kernel-3.13.11-100.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/kernel-3.13.11-100.fc19

Comment 19 Fedora Update System 2014-04-28 21:00:55 UTC
kernel-3.14.2-200.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/kernel-3.14.2-200.fc20

Comment 20 Fedora Update System 2014-05-01 22:31:24 UTC
kernel-3.14.2-200.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 21 Fedora Update System 2014-05-06 03:30:49 UTC
kernel-3.13.11-100.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.