Bug 1071973 - empty-pre-post algorithm is unable to remove empty snapshots
Summary: empty-pre-post algorithm is unable to remove empty snapshots
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: snapper
Version: 7.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: 7.1
Assignee: Ondrej Kozina
QA Contact: yanfu,wang
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-03 15:25 UTC by Ondrej Kozina
Modified: 2015-03-05 13:29 UTC (History)
6 users (show)

(edit)
The empty-pre-post cleanup algorithm, which is used for deleting pre-post pairs of file system snapshots with empty diffs, does not work in Red Hat Enterprise Linux 7. To work around this problem, remove empty pre-post snapshot couples manually by using the "delete" command.
Clone Of:
(edit)
Last Closed: 2015-03-05 13:29:45 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0569 normal SHIPPED_LIVE snapper bug fix update 2015-03-05 16:49:24 UTC

Description Ondrej Kozina 2014-03-03 15:25:16 UTC
Description of problem:
cleanup algorithm 

Version-Release number of selected component (if applicable):
snapper-0.1.7-6.el7.*

How reproducible:

have following lines in /etc/snapper/configs/<config_name> file:

# cleanup empty pre-post-pairs
EMPTY_PRE_POST_CLEANUP="yes"
# limits for empty pre-post-pair cleanup
EMPTY_PRE_POST_MIN_AGE="10" (or other low enough value in secs)


Steps to Reproduce:
1. create empty pre-post snapshot couples: snapper -c <config_name> create -c empty-pre-post --command "echo idling"
2. wait for $EMPTY_PRE_POST_MIN_AGE secs
3. snapper -c <config_name> cleanup empty-pre-post

Actual results:
[root@localhost ~]# snapper -c testsuite cleanup empty-pre-post
Config is in use.

Expected results:
Empty pre post snapshots are removed.

Comment 1 Ondrej Kozina 2014-03-05 14:55:24 UTC
upstream fix: https://github.com/openSUSE/snapper/pull/58

Comment 9 errata-xmlrpc 2015-03-05 13:29:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0569.html


Note You need to log in before you can comment on or make changes to this bug.