Bug 1071997 - VM is not locked on run once
Summary: VM is not locked on run once
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.3.5
Assignee: Arik
QA Contact: meital avital
URL:
Whiteboard: virt
Depends On:
Blocks: 1024889 1071867
TreeView+ depends on / blocked
 
Reported: 2014-03-03 16:21 UTC by Arik
Modified: 2016-02-10 19:47 UTC (History)
7 users (show)

Fixed In Version: ovirt-3.3.5-rc
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-05-08 14:17:13 UTC
oVirt Team: Virt


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 25277 0 None MERGED core: add missing engine lock in run once Never
oVirt gerrit 25329 0 None MERGED core: add missing engine lock in run once Never
oVirt gerrit 25330 0 None MERGED core: add missing engine lock in run once Never

Description Arik 2014-03-03 16:21:58 UTC
Description of problem:
We are not locking the VM when we run it in run once mode, as we do when run it normally, which might cause "split brain"

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Run VM in run once mode
2.
3.

Actual results:
VM is not locked

Expected results:
VM should be locked as it is in normal run

Additional info:
The problem is that LockIdNameAttribute is missing in RunVmOnceCommand

Comment 2 Michal Skrivanek 2014-03-04 13:23:54 UTC
pending backports

Comment 3 Sandro Bonazzola 2014-04-02 16:17:00 UTC
This is an automated message. Moving to ON_QA since this BZ should be fixed in oVrit 3.3.5 RC.

Comment 4 Sandro Bonazzola 2014-05-08 14:17:13 UTC
This is an automated message

oVirt 3.3.5 has been released:
 * should fix your issue
 * should be already available at your local mirror

If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.