Bug 107207 - Attempting to add applets to panel causes segfault in "wnck-applet"
Attempting to add applets to panel causes segfault in "wnck-applet"
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-15 16:00 EDT by Ben Steeves
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-17 20:14:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Steeves 2003-10-15 16:00:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030728
Mozilla Firebird/0.6.1

Description of problem:
When attempting to add some applets (it fails with Workspace Switcher, Window
Menu, Window List, works for Sticky Notes, Notifcation Area, and System
Monitor), I get a crash (segfault) dialog like:

Application "wnck-applet" (process 3781) has crashed
due to a fatal error.
(Segmentation fault)

In addition, when starting Workspace Switcher, I get the following dialog after
closing the segfault dialog:

The panel encountered a problem while loading "OAFIID:GNOME_WorkspaceSwitcherApplet"

Do you want to delete the applet from your configuration?

Window Menu and Window List give this instead:
The Window Menu applet appears to have died unexpectedly

Reload this applet?

I have the libwnck-2.4.0.1-1 RPM installed.

Version-Release number of selected component (if applicable):
gnome-panel-2.4.0-3

How reproducible:
Always

Steps to Reproduce:
1. Add a new panel (or use an existing one, it doesn't matter).
2. Attempt to add Window List (Right-click->Add to Panel->Utility->Window List).
3. Read the pretty crash dialog.
    

Actual Results:  The segfault dialog quoted above appears.

Expected Results:  The Window List applet should have loaded.

Additional info:

This machine was upgraded from test 2 to test 3 and then patched with the yum
repository at http://mirror.dulug.duke.edu/pub/yum-repository/redhat/rawhide/i386/

AFAIK, it's fully up to date and the RPMs are all consistent.
Comment 1 Ben Steeves 2003-10-15 20:24:52 EDT
Based on the output of rpm -V libwnck , it was discovered that a depenency
change necessitated re-running prelink.

The problem was solved by running "prelink -a".
Comment 2 Ben Steeves 2003-10-16 07:56:32 EDT
Total weirdness.  After logging out / back in, the error returned, exactly as
above.  After a reboot, it was gone again!
Comment 3 Leonard den Ottolander 2004-02-17 18:12:14 EST
Did this behaviour disappear with the release of FC 1? If so this bug
can be closed CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.