Bug 10721 - order of post and preun scripts when upgrading rpms
order of post and preun scripts when upgrading rpms
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-11 04:00 EDT by gerald
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-13 06:44:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description gerald 2000-04-11 04:00:55 EDT
If I say rpm -U xxx.new.rpm

rpm will first run the "%post" script of the new rpm before the
"%preun" script of the old rpm. This seems to be nonsense to me.

It should first do

rpm -e xxx.old.rpm

and then

rpm -i xxx.new.rpm

Gerald
Comment 1 Jeff Johnson 2000-04-13 06:44:59 EDT
This has been the behavior of rpm for A Long Time Now. See the complete
order of scriptlet execution in /usr/doc/rpm-*/triggers.

Note You need to log in before you can comment on or make changes to this bug.