Bug 1072126 - Build QtCreator 3.x with Qt 5.2.x
Summary: Build QtCreator 3.x with Qt 5.2.x
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: qt-creator (Show other bugs)
(Show other bugs)
Version: 20
Hardware: All Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Itamar Reis Peixoto
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On: 1052389
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-04 01:09 UTC by Eduardo Weiland
Modified: 2014-08-03 10:31 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-12 21:55:50 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
About QtCreator box (33.77 KB, image/png)
2014-03-04 01:09 UTC, Eduardo Weiland
no flags Details

Description Eduardo Weiland 2014-03-04 01:09:55 UTC
Created attachment 870201 [details]
About QtCreator box

Current version of QtCreator in Fedora repositories is built with Qt version 4.8.5. This removes very useful functionalities, like the welcome screen, from QtCreator in Fedora.

As per https://qt-project.org/forums/viewthread/38398, building QtCreator with Qt 5.2+ should fix this problem.


Version-Release number of selected component (if applicable):
qt-creator-3.0.1-1.fc20.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Open QtCreator

Actual results:
No welcome screen.

Expected results:
The welcome screen should be shown.

Additional info:

Comment 1 Sandro Mani 2014-03-04 08:07:26 UTC
Hi, this has been looked at, currently it is on hold because of #1052389. But I'll see whether the other comaintainers of Qt-Creator are ok with building against Qt5 regardless.

Comment 2 Sandro Mani 2014-03-12 21:55:50 UTC
qt-creator in rawhide is now built against Qt5.

qt-creator in the official Fedora repos for F20 won't be built against Qt5 since it is a too large change for a stable release. However, there is a copr repository at [1].

Closing bug.

[1] http://copr.fedoraproject.org/coprs/smani/qtcreator-qt5/

Comment 3 Brallan Jesús Aguilar Rivera 2014-08-03 05:35:29 UTC
Will be the Copr repo updated for newer versions of QtCreator?

Comment 4 Sandro Mani 2014-08-03 10:31:57 UTC
Done https://copr.fedoraproject.org/coprs/smani/qtcreator-qt5/build/24453/ (will try to remember to updated it also in the future).


Note You need to log in before you can comment on or make changes to this bug.