Bug 1072337 - DS is created after testing connection failure in domain
Summary: DS is created after testing connection failure in domain
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web Console
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: DR4
: EAP 6.3.0
Assignee: Harald Pehl
QA Contact: Jakub Cechacek
Russell Dickenson
URL:
Whiteboard:
Depends On: 1072962
Blocks: eap63-beta-blockers
TreeView+ depends on / blocked
 
Reported: 2014-03-04 12:09 UTC by Jakub Cechacek
Modified: 2015-04-28 15:08 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-28 15:44:39 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker EAP6-66 0 Major Closed Add test capability for data sources 2015-04-28 15:08:55 UTC

Description Jakub Cechacek 2014-03-04 12:09:07 UTC
Testing connection to invalid configuration will cause DS to be created in DS creation wizard in domain

Steps to Reproduce:
1. Start EAP 6.3 domain, open Web Console, navigate to datasources
2. Go through wizard steps (use invalid configuration) on step 3 hit "Test Connection" 
3. a) click done 
   b) click cancel  

Actual results:
   a) an error messages informing about already existing DS
   b) after reload DS is created anyway

Expected results:
   a) DS should be created only AFTER the wizard is finished 
   b) DS should not be created

Comment 1 Rostislav Svoboda 2014-03-04 12:40:23 UTC
Setting blocker? flag as it's needed to fix this BZ for https://issues.jboss.org/browse/EAP6-66

Comment 2 Jakub Cechacek 2014-03-05 11:32:19 UTC
AFAIK the "Test Connection" feature creates a temporary DS which is configured in the exactly same configuration as entered in wizard (same name, jndi, etc..) and not remove afterwards.

This can be verified through CLI after using the "Test Connection" functionality in the wizard.

Comment 3 Harald Pehl 2014-03-05 13:57:23 UTC
Caused by a wrong recovery from a management operation

Comment 4 Jakub Cechacek 2014-03-21 11:14:11 UTC
This is most likely fixed (I haven't noticed this issue in DR4). Not sure why it didn't reach QA. Requesting info from Harald.

Comment 5 Harald Pehl 2014-03-21 11:21:41 UTC
Yes this was fixed as part of 1072962. Please remove beta blocker.

Comment 6 Kabir Khan 2014-04-02 17:17:27 UTC
Fixed for console upgrade in DR4

Comment 7 Jakub Cechacek 2014-04-03 07:13:02 UTC
Verified as per comments above.

Comment 8 Scott Mumford 2014-05-14 00:53:36 UTC
Marking for exclusion from 6.3.0 Beta release notes as both 'affects' and 'fix' versions are listed as 6.3.0, suggesting this was not a customer-facing issue.

Comment 9 JBoss JIRA Server 2015-04-28 15:08:57 UTC
John Doyle <jdoyle@jboss.org> updated the status of jira EAP6-66 to Closed


Note You need to log in before you can comment on or make changes to this bug.