Bug 107247 - SCSI Tape is recognized as "st" instead of "st0" on IBM pSeries
Summary: SCSI Tape is recognized as "st" instead of "st0" on IBM pSeries
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ready Certification Tests
Classification: Retired
Component: rhr2-tests   
(Show other bugs)
Version: 2
Hardware: powerpc
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Rob Landry
QA Contact: Rob Landry
URL:
Whiteboard:
Keywords:
Depends On: 107361
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-16 03:49 UTC by Ren Dang En
Modified: 2007-04-18 16:58 UTC (History)
0 users

Fixed In Version: kudzu-1.1.22-1.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-06 01:04:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ren Dang En 2003-10-16 03:49:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
rhr2-externals-0.9-11
rhr2-tests-0.9-11
rhr2-0.9-11

on all pSeries boxes(e.g. p630, p650), the first scsi tape is identitied 
as "st" by rhr2 hardware detection(in hardware.conf). 
When we choose to test "Tape", it gives us the following message in error.log:
    WARNING: does not appear to be valid
    /dev/st: No such file or directory

In fact, st should be "st0", then the test is OK.

We noticed that this tape test call "kudzu -q" first,
in the generated "hwconf" file, tape device is "st".



Version-Release number of selected component (if applicable):
rhr2-tests-0.9-11

How reproducible:
Always

Steps to Reproduce:
1. install rhr2
2. run redhat-ready, pembroke and discovery
3. run tape test
    

Additional info:

Comment 1 Rob Landry 2003-10-16 17:25:50 UTC
I can work around that in the detection sripts; but this should as quickly as
possible be opened up as a kudzu bug (our data is based on the kudzu output so
we really should fix the root cause) expecially since rhn and the installer rely
on the output of kudzu as well (I'm not certain the true impact it would/will
have on those)

Comment 2 Ren Dang En 2003-10-20 02:58:36 UTC
Hi Rob,
bug 107361 is opened against kudzu, and the fix provided is just fine. 
Thanks!

Comment 3 Rob Landry 2003-10-20 14:41:45 UTC
Excellent, from how I read the kudzu bug; it appears the kudzu update isn't
going to make the Gold CD; but instead would be released as either an errata
and/or on Update 1; this means in the interim you'll need to edit
/etc/rhr/hardware.conf and correct the TAPE line since I am not planning on
writting a work around I'll just have to remove later.  Does this sound acceptable?

Comment 4 Ren Dang En 2003-10-21 00:44:26 UTC
That's fine, Rob. 
We'll reverify it when QU 1 comes out.

Comment 5 Ren Dang En 2004-01-06 01:04:25 UTC
Hi Rob, fix is included in QU1. So it can be closed.


Note You need to log in before you can comment on or make changes to this bug.