Bug 1072523 - docker-registry settings in /etc/sysconfig/docker-registry not honored
Summary: docker-registry settings in /etc/sysconfig/docker-registry not honored
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: docker-registry
Version: el6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Marek Goldmann
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-04 17:16 UTC by Adam Miller
Modified: 2018-12-05 17:31 UTC (History)
2 users (show)

Fixed In Version: docker-registry-0.6.8-1.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-02 17:31:02 UTC
Type: Bug


Attachments (Terms of Use)
possible patch (443 bytes, patch)
2014-04-07 09:02 UTC, Stuart Auchterlonie
no flags Details | Diff

Description Adam Miller 2014-03-04 17:16:18 UTC
Description of problem:
docker-registry does not honor settings in /etc/sysconfig/docker-registry

Version-Release number of selected component (if applicable):
docker-registry-0.6.0-4.el6.noarch


How reproducible:
Always

Steps to Reproduce:
1. Enable EPEL on a RHEL6 machine
2. yum install docker-registry
3. service redis start
4. service docker-registry start
5. curl localhost:5000

Actual results:
docker-registry response is (dev) even though by default in /etc/sysconfig/docker-registry the setting is "local"


Expected results:
docker-registry response to be (local) 


Additional info:
It looks like the variable aren't being exported into the environment of the shell environment that starts the gunicorn process from the init script. If you add "export" to the variables set in /etc/sysconfig/docker-registry it works:

# cat /etc/sysconfig/docker-registry 
# The Docker registry configuration file
# DOCKER_REGISTRY_CONFIG=/etc/docker-registry.yml

# The configuration to use from DOCKER_REGISTRY_CONFIG file
export SETTINGS_FLAVOR=dev

# Address to bind the registry to
export REGISTRY_ADDRESS=0.0.0.0

# Port to bind the registry to
export REGISTRY_PORT=5000

# Number of workers to handle the connections
export GUNICORN_WORKERS=8

Comment 6 Fedora Update System 2014-04-07 13:31:09 UTC
docker-registry-0.6.6-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/docker-registry-0.6.6-2.el6

Comment 7 Fedora Update System 2014-04-09 05:27:30 UTC
Package docker-registry-0.6.6-2.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing docker-registry-0.6.6-2.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-1087/docker-registry-0.6.6-2.el6
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2014-04-18 14:09:20 UTC
docker-registry-0.6.8-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/docker-registry-0.6.8-1.el6

Comment 9 Fedora Update System 2014-04-18 14:09:28 UTC
docker-registry-0.6.8-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/docker-registry-0.6.8-1.fc20

Comment 10 Fedora Update System 2014-04-18 14:09:36 UTC
docker-registry-0.6.8-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/docker-registry-0.6.8-1.fc19

Comment 11 Stuart Auchterlonie 2014-04-29 08:38:49 UTC
Is this getting pushed to EPEL stable any time soon?

Comment 12 Marek Goldmann 2014-04-29 08:43:09 UTC
(In reply to Stuart Auchterlonie from comment #11)
> Is this getting pushed to EPEL stable any time soon?

It awaits positive Karma on Koji: https://admin.fedoraproject.org/updates/docker-registry-0.6.8-1.el6

Comment 14 Fedora Update System 2014-06-02 17:31:02 UTC
docker-registry-0.6.8-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2014-06-10 02:53:55 UTC
docker-registry-0.6.8-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2014-06-10 03:07:24 UTC
docker-registry-0.6.8-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.