Bug 107257 - OpenOffice needs StartupNotify=true in desktop files
Summary: OpenOffice needs StartupNotify=true in desktop files
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-16 07:45 UTC by Alexander Larsson
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-27 15:30:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alexander Larsson 2003-10-16 07:45:01 UTC
It seems OpenOffice already supports startup notification. Its just that the
desktop files doesn't specify it, so its not used.

If we add StartupNotify=true in the desktop files, and startup_notify=true for
openoffice in /usr/share/application-registry/gnome-vfs.applications startup
notification will work both from the menu and from nautilus.

There seems to be some issues with startup notification when launching the
second window though. Luckily michael seems to have a fix for this:
http://cvs.gnome.org/lxr/source/openoffice/patches/OOO_1_1/startup-fix.diff

If we add this patch and the desktop file changes i'll do the required changes
to gnome-vfs.applications.

Comment 1 Dan Williams 2003-10-16 16:46:01 UTC
Alex,

I've added a piece to the specfile to echo "StartupNotify=true" to the *.desktop
files.  If you could do the gnomevfs.applications that would be great.

Comment 2 Alexander Larsson 2003-10-17 07:48:17 UTC
gnome-mime-data-2.4.0-2 has the gnome-vfs.application change. Test it by double
clicking on an OOo document in nautilus.


Comment 3 Dan Williams 2003-10-27 15:30:46 UTC
Fixed in 1.1.0-3.


Note You need to log in before you can comment on or make changes to this bug.