Bug 1072610 - Should not propose to install from CD/DVD in RHEL7
Summary: Should not propose to install from CD/DVD in RHEL7
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-manager
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Giuseppe Scrivano
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords:
: 1188527 (view as bug list)
Depends On: 760885
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-04 21:42 UTC by Marc-Andre Lureau
Modified: 2016-02-10 19:10 UTC (History)
7 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-06-13 11:52:21 UTC


Attachments (Terms of Use)

Description Marc-Andre Lureau 2014-03-04 21:42:05 UTC
Description of problem:

CD/DVD host passthrough has been disabled in RHEL7. See #760885

How reproducible:
100%


Steps to Reproduce:
1. Setup a new VM using host CD/DVD drive
2.
3.

Actual results:
fails (see #760885 for reported error)

Expected results:
Shouldn't propose to install from host CD/DVD

Additional info:
I personally think this is pretty sad, as I don't see an easy way to install from hard cd/dvd...

Comment 2 Giuseppe Scrivano 2014-03-05 15:13:19 UTC
I think this can be easily removed from the UI only.

The virt-install documentation needs to be fixed too.

Comment 3 tingting zheng 2014-03-12 07:27:55 UTC
There is bug 1038926 to record all the GUI of virt-manager which is not supported by qemu-kvm on rhel7.0.The cdrom has mentioned in comment 7 in that bug.

Comment 6 tingting zheng 2014-03-24 06:05:41 UTC
Tested with:
virt-manager-0.10.0-19.el7.noarch

Steps:
1.Test create a new guest:
Open virt-manager,click to create a new guest,choose "Local install media(ISO image or CDROM),click "Forward",on the next GUI,"use CDROM or DVD" has been disabled.

2.Test add cdrom for an existing guest:
For an existing guest,click "Add hardware"->Storage->"IDE CDROM"->"Finish".

On the guest hardware details GUI,click "IDE CDROM"->"Connect"->"CDROM or DVD" option has been disabled.

3.Test add cdrom for an existing guest and set storage path as "/dev/cdrom".
For an existing guest,click "Add hardware"->Storage->"IDE CDROM"->set storage Path as "/dev/cdrom"->"Finish".

Try to boot the guest,will get error:
Error starting domain: internal error: process exited while connecting to monitor: qemu-kvm: -drive file=/dev/cdrom,if=none,id=drive-ide0-1-0,readonly=on,format=raw,cache=none: could not open disk image /dev/cdrom: Driver 'host_cdrom' is not whitelisted

For item 3,is it necessary to disable /dev/cdrom as storage path?

Comment 7 Giuseppe Scrivano 2014-03-24 08:30:49 UTC
I think it is fine to allow users to set any desired value and let libvirt complain in case it is not valid.  As you've showed, This seems sufficient when they try to manually use "/dev/cdrom".

Comment 8 tingting zheng 2014-03-24 08:33:03 UTC
(In reply to Giuseppe Scrivano from comment #7)
> I think it is fine to allow users to set any desired value and let libvirt
> complain in case it is not valid.  As you've showed, This seems sufficient
> when they try to manually use "/dev/cdrom".

okay,then I move the bug to VERIFIED.

Comment 9 Cui Lei 2014-03-24 08:34:15 UTC
Added tested with virt-install:
virt-install-0.10.0-19.el7.noarch

[root@localhost ~]# virt-install -n test -r 512 -s 6 --cdrom /dev/sr0 -f /var/lib/libvirt/images/test.img

Starting install...
Allocating 'test.img'                                                                                                                                                 | 6.0 GB  00:00:00     
ERROR    internal error: process exited while connecting to monitor: qemu-kvm: -drive file=/dev/sr0,if=none,id=drive-ide0-1-0,readonly=on,format=raw: could not open disk image /dev/sr0: Driver 'host_cdrom' is not whitelisted


@Giuseppe:
from comment2, you said "The virt-install documentation needs to be fixed too.". But both of the manual doc and help doc did not mention about Physical CDROM was not supported. For example, the first example in manual doc:
...installing from media in the hosts CDROM drive...

         # virt-install \
              --connect qemu:///system \
              --virt-type kvm \
              --name demo \
              --ram 500 \
              --disk path=/var/lib/libvirt/images/demo.img,size=8 \
              --graphics vnc \
              --cdrom /dev/cdrom \
              --os-variant fedora13

The example should be removed.

Do we need to file another bug for the virt-install document update? or you just send a new patch for doc update?

Comment 10 Giuseppe Scrivano 2014-03-24 09:22:28 UTC
I am going to prepare a new patch to drop that example from the documentation

Comment 11 Cui Lei 2014-03-24 09:49:47 UTC
List the document which need to update I found(check my comments after >>):
1. virt-manager -h
...
--cdrom=CDROM       CD-ROM installation media
...

>>As physical cdrom are not supported, only could be path to an ISO image.

2. man virt-manager
...
       --cdrom=CDROM
         File or device use as a virtual CD-ROM device for fully virtualized guests.  It can be path to an ISO image, or to a CDROM device. It can also be a URL from which to
         fetch/access a minimal boot ISO image. The URLs take the same format as described for the "--location" argument. If a cdrom has been specified via the "--disk" option, and
         neither "--cdrom" nor any other install option is specified, the "--disk" cdrom is used as the install media.
...

>>remove ", or to a CDROM device". Announce that physical cdrom is not supported.

3. Remove the first example in manual doc.

Any other parts you think are related with physical cd/dvd were not supported, please go ahead to update.

Comment 12 Giuseppe Scrivano 2014-03-24 10:46:02 UTC
1) cannot be changed at this point as it is a localized message (and it looks fine as it is)

I'll drop the reference to the physical CDROM device from the man page.

Comment 15 Cui Lei 2014-03-25 01:53:17 UTC
Verified this issue with:
virt-manager-0.10.0-20.el7.noarch
virt-manager-common-0.10.0-20.el7.noarch
virt-install-0.10.0-20.el7.noarch

1. cdrom option have been update as:
       --cdrom=CDROM
         File to use as a virtual CD-ROM device for fully virtualized guests.  It can be path to an ISO image or a URL from which to fetch/access a minimal boot ISO image. The URLs
         take the same format as described for the "--location" argument. If a cdrom has been specified via the "--disk" option, and neither "--cdrom" nor any other install option is
         specified, the "--disk" cdrom is used as the install media.

It looks fine.

2. The physical cdrom example have been removed.

So change the status from 'ON_QA' to 'VERIFIED'

Comment 16 Ludek Smid 2014-06-13 11:52:21 UTC
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Comment 18 Giuseppe Scrivano 2015-02-03 08:52:20 UTC
*** Bug 1188527 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.