Bug 107263 - konsole gives false error messages
Summary: konsole gives false error messages
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-16 09:32 UTC by Hans de Goede
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-21 20:31:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Hans de Goede 2003-10-16 09:32:25 UTC
Starting konsole from a terminalemulator, gives amongst other output:
konsole: cannot chown /dev/pts/1.
Reason: Operation not permitted
konsole_grantpty not installed root-suid
konsole: chownpty failed for device /dev/pts/1::/dev/pts/1.
       : This means the session can be eavesdroped.
       : Make sure konsole_grantpty is installed in
       : /usr/bin/ and setuid root.
konsole_grantpty not installed root-suid

This is ofcourse a bogus messages, since this isn't needed with devpts, but for
some reason konsole doesn't detect this and screams. I'm afraid this could
confuse users and lead to false bugreports.

Quick fix: don't include konsole_grantpty in the RPM, instead just make a
symlink named konsole_grantpty to /bin/true.
IOW put this in the install part of the spec:

rm -f /usr/bin/konsole_grantpty
ln -s /bin/true /usr/bin/konsole_grantpty

But you need to adjust this for the install root ofcourse.
Let me know if you want this bug to be reported upstream.

Comment 1 Hans de Goede 2004-07-21 20:31:07 UTC
No longer there in FC3-test1, maybe gone in earlier releases too.



Note You need to log in before you can comment on or make changes to this bug.