Bug 107264 - [RFE] option to de-select partition for swap
[RFE] option to de-select partition for swap
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
high Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
FC2
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-16 05:52 EDT by Gene Czarcinski
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-15 11:30:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2003-10-16 05:52:33 EDT
Description of problem:
I was sure this had been submitted sometime, but apparently it has not.

During the install, the current way to idnetify a swap partition is to look for
the swap "signature".  All partitions with a "swap signature" are then selected
as swap partitions for the install and will be formatted.

Request:  there should be an option to DEselect a swap partition.

Example where this current situation is a problem:  Use vmware to install a
linux guest.  The install will be a harddisk install.  The running host system
has a swap partition on the same physical disk as the partition holding the iso
images.  If I proceed, I just formatted the running host systems swap partition.
 Bang!

There are other examples such as where you have disks physically shared between
two separate hardware systems.

In addition, see discussion on the fedora-test-list.
Comment 1 Jeremy Katz 2003-10-21 11:42:39 EDT
Ermm, your example seems very broken.  Why are you putting the ISOs in a swap
partition?  The swap signature should only be there if it's an actual swap
partition and not an ext[23] partition (which is what you should be putting ISOs
on).

I will turn off the forced formatting for FC2, though.  It's just far too late
to do that for this release -- I'm not entirely sure what other side effects
could pop up and without another test release, there's no way to really be able
to verify it to the extent that I'd want to.
Comment 2 Gene Czarcinski 2003-10-21 13:02:21 EDT
OK, I was not clear so let me try again.  I believe my example will apply to
building a guest system under VMware or building a system on a drive which will
then be removed and install on a separate (different) system.

1.  The system will be installed on on VMware virtual drive (e.g., /dev/sda) --
this is one or more files on the real (host) system.  That virtual drive will
also have a swap partition.

2.  I will be doing a harddisk install with the iso images in a partition in a
real drive (e.g., /dev/hdb) on the host system.  This drive also contains a swap
partition which is in use by the host system.

The install of the guest will also format the host's swap partition.

I believe that there are other scenarios which involve building a linux system
on a drive which is then installed on another (different) system without the
second drive.

Yet another example is where I build a minimu (emergency) system on a drive and
I do not want it to depend on anything else except the absolute minimum.  I know
I can fix this after installation but would like to do it at install time.

These may be some corner cases but they do exist in the real world.  I am having
a bit of difficulty seeing the reluctance of providing the option.

BTW, my workaround for the VMware example cited above is to do an nfs install
rather than a harddisk install.
Comment 3 Gene Czarcinski 2003-10-21 13:06:23 EDT
FC 2 is fine with me since I do have my workaround.

Some additional examples of where this option would be useful is where you have
physically shared drives and some swap areas are in use by an additional system.

BTW, the RFE is NOT to just don't format it ... don't USE it.
Comment 4 Gene Czarcinski 2003-10-21 13:28:25 EDT
Some additional clarification ...

For VMware to do the install of the guest it has to "see" both the virtual
partition which only contains and "empty" virtual drive AND the full (real)
partition which has the iso images partitions AND the swap partition used by the
host system which is running VMware.
Comment 5 Jeremy Katz 2004-01-06 18:53:33 EST
No longer auto-formatting.  Not using isn't really sanely doable
within the current interface :/

Note You need to log in before you can comment on or make changes to this bug.