Bug 107296 - Problems accessing NFS files served up from Solaris 9.0
Problems accessing NFS files served up from Solaris 9.0
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-16 12:53 EDT by Tim Johnson
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-10 13:09:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from 'strace' (7.68 KB, text/plain)
2003-10-16 13:00 EDT, Tim Johnson
no flags Details

  None (edit)
Description Tim Johnson 2003-10-16 12:53:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030919

Description of problem:
'ls' wedges in an NFS directory that is served up by Solaris 9.0. The first
symtom of the problem was the inability to login to an pre-existing account
(login would start, file system automounts, then wedge). On a brand new account
you could login from 'rlogin' but not the X console. Once an attempt was made to
login from the X display ('.' files/dirs created by KDE), you could no longer
rlogin (or even 'ls' from another account).

Same directory is fully accessable from Solaris clients. Same problem occurs on
RedHat 7.1 & 8.0. I have disabled 'autofs'. When gnome is used instead of KDE,
same result. 

The solaris file servers is a cluster, the other member is older hardware
running Solaris 8.0 and it has been working for some time.

The Solaris cluster is SAN based and running 'veritas'.

Our current work-around is expected to be installing Solaris 8.0 on the new
hardware.

Version-Release number of selected component (if applicable):
kernel-2.4.21-3.EL

How reproducible:
Always

Steps to Reproduce:
1. Create account with empty home directory located on a Solaris 9 File server.
2. Manually mount home directory on AWS client.
3. Login to X display with the account (KDE) Login will not complete. Multiple
'.' files/directories will be created.
4. Reboot AWS client.
5. Login as another user. 'cd ~account ; ls'. ls will wedge. Leave it running or
reboot.
6. Login to server (or nfs from solaris) rm -r ~account/.kde
7. The ls command on the AWS client will now complete.
    

Actual Results:  'ls' never returns, load average continues to rise. The CPU is
just idling.

Additional info:

I will be attaching the output from both a successfull and a failed 'strace ls'.
Comment 1 Tim Johnson 2003-10-16 13:00:56 EDT
Created attachment 95230 [details]
Output from 'strace'

Archive contains two files: ok.out & wedge.out. The first was when the ls
completed (no .kde dire) the second was when ls wedged (.kde dir present).
Comment 2 Steve Dickson 2003-10-20 13:40:54 EDT
Would it be possible to get a ethereal trace (i.e. ethereal -o output)
of this problem?

Note You need to log in before you can comment on or make changes to this bug.