Bug 107309 - Xawtv segfaults on saa7134 (and 2.6-test kernel)
Xawtv segfaults on saa7134 (and 2.6-test kernel)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xawtv (Show other bugs)
rawhide
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks: FC3BugWeekTracker
  Show dependency treegraph
 
Reported: 2003-10-16 15:13 EDT by Eirik Thorsnes
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-28 17:08:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eirik Thorsnes 2003-10-16 15:13:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20030927

Description of problem:
Note that this is tested on 2.6-test7 (arjanv) because:
The saa7134 module and accompaning v4l2 modules (downloaded and tried different
versions from bytesex.org) fails to work (module loads with errors in dmesg and
xawtv says cannot find device) on the shipping 2.4 kernel in Fedora.

The modules in 2.6 loads without errors, but xawtv segfaults right after start
(window shows only briefly).

Note that the same 2.6 kernel works together with xawtv in Red Hat Linux 9, and
saa7134 + v4l2 modules work in Red Hat Linux 9 with 2.4 kernel loaded.

Version-Release number of selected component (if applicable):
xawtv-3.88-5

How reproducible:
Always

Steps to Reproduce:
1. Install 2.6-test kernel from people.redhat.com/arjanv
2. modprobe saa7134
3. run xawtv
    

Actual Results:  Program segfaults

Expected Results:  Should continue to run without segfault

Additional info:

Tv card type: Terratec 400
Desktop: KDE
Comment 1 Eirik Thorsnes 2003-10-25 20:16:01 EDT
Backtrace on core dump:
(gdb) bt
#0  0x00a9904e in _mesa_test_os_sse_exception_support () from
/usr/X11R6/lib/modules/dri/tls/mga_dri.so
#1  0x00a98d71 in check_os_sse_support () from
/usr/X11R6/lib/modules/dri/tls/mga_dri.so
#2  0x00a98c20 in sigill_handler () from /usr/X11R6/lib/modules/dri/tls/mga_dri.so
Previous frame inner to this frame (corrupt stack?)
(gdb) quit

I have a Matrox G450 Card, standard XFree86 drivers.
Same bug and backtrace on xawtv-3.90 from bytesex.org.
Should I try Matrox own drivers?
Comment 2 Eirik Thorsnes 2003-10-25 21:40:44 EDT
Copying the mga_dri.o from Red Hat Linux 9 XFree86 4.3.0 package into
/usr/X11R6/lib/modules/dri/
and rename (move) /usr/X11R6/lib/modules/dri/tls/ (to make it use the files in
the first directory) brings back functionality, that is: no segfault and xawtv
shows tv.

I can reproduce the same segfault and backtrace on glxgears with the Fedora
mga_dri.o with 2.6 kernel, but not on 2.4 shipped kernel (but with 2.4 my
TV-card won't work so I can't test xawtv here - although it doesn't segfault on
startup).


Summary: Something changed in mga_dri.o from RH 9 to Fedora that makes it
segfault on 2.6 kernel in certain situations. Should this bug be moved to
XFree86 component or kernel component?
Comment 3 Alan Cox 2004-06-21 13:01:47 EDT
We've got an open bug for that already for FC2 so this beta bug can be
closed. Its still not fixed it seems
Comment 4 Marcin Garski 2004-09-28 17:08:26 EDT
Thanks for the bug report. However, Red Hat no longer included xawtv
in Fedora Core. It has been replaced by tvtime.
Please upgrade to the latest version of Fedora Core and open a new bug
if the problem also occur in tvtime.

If you still use xawtv and this bug still persists, please report the
problem in upstream bug tracker or on mailing list
(usualy they can be found on xawtv website
http://linux.bytesex.org/xawtv/).
If the project don't have bug tracker and mailing list, you should
sent bug report by email to xawtv maintainer.
Also Fedora Legacy Project (http://fedoralegacy.org/) maintains some
older releases, and if you believe this bug is interesting to them,
please report the problem in the bug tracker at:
http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.