Bug 107311 - xconfig cant handle dep_bool
xconfig cant handle dep_bool
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brian Maly
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-16 15:30 EDT by ginnie nuckles
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-19 16:18:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ginnie nuckles 2003-10-16 15:30:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; FunWebProducts)

Description of problem:
on  Red Hat Enterprise Linux release 2.9.5AS (Taroon)


when running  make xconfig  out of the /usr/src/linx-release-dir 
the follow error is recieved 


 make xconfig
rm -f include/asm
( cd include ; ln -sf asm-i386 asm)
make -C scripts kconfig.tk
make[1]: Entering directory `/usr/src/linux-2.4.21-1.1931.2.399.ent/scripts'
cat header.tk >> ./kconfig.tk
./tkparse < ../arch/i386/config.in >> kconfig.tk
drivers/net/wan/Config.in: 44: can't handle dep_bool/dep_mbool/dep_tristate 
condition
make[1]: *** [kconfig.tk] Error 1
make[1]: Leaving directory `/usr/src/linux-2.4.21-1.1931.2.399.ent/scripts'
make: *** [xconfig] Error 2



Please advise

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.cd to /usr/src/linux-release 
2. make xconfig
3.
    

Actual Results:  see above 

Expected Results:  xwindows configuration menu should appear

Additional info:
Comment 1 Mike A. Harris 2003-10-16 20:03:51 EDT
Xconfigurator is the Red Hat XFree86 X server configuration program which
you get when you type "Xconfigurator" at the command prompt as root.  ;o)

You are trying to configure a kernel build, which is unrelated.  Reassigning
to the kernel component.
Comment 2 Arjan van de Ven 2003-10-17 03:45:49 EDT
this was a Config.in bug we since fixed.....
Comment 3 Red Hat Bugzilla 2007-03-18 18:16:03 EDT
User jparadis@redhat.com's account has been closed

Note You need to log in before you can comment on or make changes to this bug.