Bug 107313 - Up2date fails using a proxy server
Summary: Up2date fails using a proxy server
Status: CLOSED DUPLICATE of bug 102272
Alias: None
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Fanny Augustin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-16 19:34 UTC by Mario
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:59:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mario 2003-10-16 19:34:53 UTC
Description of problem:


Version-Release number of selected component (if applicable):

Fedora Beta 3

How reproducible:

Always when you need to use a Proxy server.


Steps to Reproduce:
1. Set parameter http_proxy="server_name:port" and export the variable
    In my case  I don't need a username/passwd

2. Run up2date -u 


    
Actual results:

Fetching package list for channel: rawhide...
                                                                               
                               
Fetching http://ftp.redhat.com/pub/redhat/linux/rawhide//headers/header.info...
########################################
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1183, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date", line 761, in main
    fullUpdate, dryRun=options.dry_run))
  File "/usr/sbin/up2date", line 1046, in batchRun
    batch.run()
  File "up2dateBatch.py", line 58, in run
  File "up2dateBatch.py", line 96, in __findPackagesToUpdate
  File "packageList.py", line 117, in run
  File "rhnPackageInfo.py", line 315, in getAvailableAllArchPackageList
  File "rhnPackageInfo.py", line 153, in availablePackageList
  File "rpcServer.py", line 109, in doCall
  File "repoDirector.py", line 20, in listPackages
  File "rpmSource.py", line 226, in listPackages
  File "/usr/share/rhn/up2date_client/repoBackends/yumRepo.py", line 223, in
listPackages
    (envra, rpmPath) = string.split(line, '=')
ValueError: unpack list of wrong size
 



Expected results:

To update my system

Additional info:

This works  fine if I run up2date in a machine connected directly to internet

Comment 1 Mario 2003-10-16 19:53:49 UTC
Oops, I forgot to say that up2date fails when the machine is inside a network
and you use a proxy for up2date

Comment 2 Mario 2003-10-16 19:58:28 UTC
I also tried to define the proxy server in /etc/wgetrc to see if there was any
difference but nothing changed



Comment 3 Mario 2003-10-16 20:02:59 UTC
As additional information. This functionality worked fine in Beta 2

Comment 4 Mario 2003-10-20 14:21:13 UTC
I installed:

up2date-4.1.7-1
up2date-gnome-4.1.7-1


And I get: 

# up2date -u
 
Fetching package list for channel: rawhide...
 
Fetching http://ftp.redhat.com/pub/redhat/linux/rawhide//headers/header.info...
There was some sort of I/O error: <urlopen error (110, 'Connection timed out')>



Comment 5 Michael Young 2003-10-20 22:47:04 UTC
Duplicate of bug 102272 .

Comment 6 Nils Philippsen 2003-11-29 11:19:05 UTC

*** This bug has been marked as a duplicate of 102272 ***

Comment 7 Red Hat Bugzilla 2006-02-21 18:59:13 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.