Bug 107314 - Lack of "Reset to Default" or Cancel options in control-center apps
Summary: Lack of "Reset to Default" or Cancel options in control-center apps
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: control-center (Show other bugs)
(Show other bugs)
Version: 9
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Blandford
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-16 20:12 UTC by Cristian Gafton
Modified: 2013-04-02 04:18 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-17 14:44:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Cristian Gafton 2003-10-16 20:12:52 UTC
A lot of the programs under the control-center management have a poor design by
not having a "cancel" or some other way of resetting changes to the default
state. Take for example the keyboard shortcut editor. Once you change a key
binding in there there is NO WAY to change your mind. You better not click on
something you had not intended or you will be sorry.

The same thing goes for pretty much all the applications part of the
control-center. It is nice to see instantly what you change, but it is dumb to
not be able to hit "Cancel" and get on with life.

One could save the state of the user settings before launching a config applet
and then offer the user the chance to revert to that last set.

Comment 1 Jonathan Blandford 2003-10-17 14:44:52 UTC
Filed upstream as http://bugzilla.gnome.org/show_bug.cgi?id=94716


Note You need to log in before you can comment on or make changes to this bug.