Bug 107317 - netgroups in /etc/hosts.equiv shifted to lower case before use
Summary: netgroups in /etc/hosts.equiv shifted to lower case before use
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
(Show other bugs)
Version: 9
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-16 20:32 UTC by jbuehler
Modified: 2016-11-24 14:57 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-27 08:03:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch that works for libc-5.4.35 (1.88 KB, patch)
2003-10-16 20:51 UTC, jbuehler
no flags Details | Diff

Description jbuehler 2003-10-16 20:32:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.5) Gecko/20031007

Description of problem:
My RedHat 9 system does not work correctly with netgroups
in /etc/hosts.equiv of the following form:

+@all-machines-A

I ran strace on in.rshd and the problem is that the queries
going to the NIS server have shifted the group name to
lower case.  I.e. glibc (I think is where the code is)
is querying all-machines-a instead of all-machines-A.

This is incorrect behavior -- neither HPUX, SUN nor AIX
client machines touch the case of the netgroup name.


Version-Release number of selected component (if applicable):
glibc-2.3.2-11.9 rsh-server-0.17-14

How reproducible:
Always

Steps to Reproduce:
1. set up a netgroup named all-machines-A that contains (somehost,,)
2. put +@all-machines-A in /etc/hosts.equiv
3. try to rsh in to the machine from host "somehost" (as set up in step 1)
4. the login will require a password because the name sent to the nis server is
incorrect
5. Note that I am using an AIX NIS server -- for all I know the RedHat server
shifts everything to lower case so this will work in an all RedHat network...
6. Also note -- changing the case of the netgroup on the NIS server to all
lower-case will make things work.
    

Actual Results:  get prompted for password

Expected Results:  It should have let me in without a password.

Additional info:

Putting an explicit entry in my .rhosts works properly, but I am prevented from
using the netgroup as I should be able to.

Comment 1 jbuehler 2003-10-16 20:51:52 UTC
Created attachment 95238 [details]
patch that works for libc-5.4.35

This patch works for linux libc-5.4.35, if it helps any for glibc...

Comment 2 Ulrich Drepper 2003-10-27 08:03:20 UTC
This is no bug, transforming the string to lowercase is intended.  This is the
traditional behavior and still what the BSDs do as far as I can see (see for
instance
http://www.freebsd.org/cgi/cvsweb.cgi/src/lib/libc/net/rcmd.c?rev=1.38&content-type=text/x-cvsweb-markup).
 If some commercial Unixes do something else it is their problem.  Changing this
in glibc would upset those depending on the current behavior.

The solution is easy: never use uppercase characters.


Note You need to log in before you can comment on or make changes to this bug.