Bug 107322 - a2ps cannot find pcrr8a.afm
a2ps cannot find pcrr8a.afm
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: a2ps (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-16 17:11 EDT by Orion Poplawski
Modified: 2007-04-18 12:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-12 16:14:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2003-10-16 17:11:16 EDT
Description of problem:
a2ps fails with:

a2ps: cannot find file `pcrr8a.afm': No such file or directory

Version-Release number of selected component (if applicable):

a2ps-4.13b-28

How reproducible:
  Everytime

Steps to Reproduce:
1.  Setup RH9 printing with LPRng to HP LJ5m or similar
2.  Print pdf file with acroread with courier font?
3.
    

Additional info:
  Server is stripped down, no KDE or GNOME components.  The font in question is
at:/usr/share/texmf/fonts/afm/adobe/courier/pcrr8a.afm, from the texmf package,
although it is apparently also in the gnome-print package which I don't want to
install.

  /etc/a2ps.conf does not reference the texmf font directories (of which there
are a lot).  Is is possible to tell a2ps in a2ps.conf to search all
subdirectories of a path element?
Comment 1 Tim Johnson 2004-01-15 13:58:35 EST
This same problem exists with AWS3.0.

I don't understand what exactly is happening but I discovered that by
uninstalling/installing a2ps it seems to work just fine.

--> a2ps foo
a2ps: cannot find file `pcrr8a.afm': No such file or directory
--> locate pcrr8a.afm
--> rpm -e a2ps
--> rpm -i a2ps-4.13b-28.i386.rpm
--> updatedb
--> locate pcrr8a.afm
--> a2ps foo

Note that pcrr8a.afm is still not available but a2ps no longer
references it. The rpm tetex-afm-1.0.7-66 contains the file:        
/usr/share/texmf/fonts/afm/adobe/courier/pcrr8a.afm. That particular
RPM is not currently installed on our systems.

My current work-around is to not install a2ps as part of Kickstart and
install it after Kickstart is complete.

I can document exactly what is installed if that would be useful.

Comment 2 Tim Waugh 2004-01-16 11:44:06 EST
I suspect this is due to a missing PreReq in the spec file.  I've
added this:

PreReq: sed, coreutils

to the rawhide package.  Could you verify that your installation is
installing one or both of the above packages *after* a2ps?  Either
could cause this I think.
Comment 3 Orion Poplawski 2005-01-12 16:14:05 EST
Suspect this is no longer an issue.

Note You need to log in before you can comment on or make changes to this bug.