Bug 107332 - get the following error while exec'ing. unexpected PLT reloc type 0x00
Summary: get the following error while exec'ing. unexpected PLT reloc type 0x00
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: glibc   
(Show other bugs)
Version: 2.1
Hardware: i686
OS: Linux
high
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-16 23:20 UTC by Shailesh Phansalkar
Modified: 2016-11-24 15:26 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-28 08:15:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Shailesh Phansalkar 2003-10-16 23:20:58 UTC
Description of problem:

Get this error message while exec'ing my application and exec fails.
error while loading shared libraries: unexpected PLT reloc type 0x00

I get this only when I compile the app using -g and not when I use any 
optimization flags like +O2.


Version-Release number of selected component (if applicable):
glibc-2.2.4-32.8
gcc-2.96-118.7.2
2.4.9-e.27smp #1 SMP 

How reproducible:

happens every time.


Steps to Reproduce:
1. Exec the application.
2.
3.
    
Actual results:


Expected results:


Additional info:

Comment 1 Ulrich Drepper 2004-09-28 08:15:21 UTC
This means your binary is not build correctly.  In the relocation
section containing the PLT relocations you have an entry encoded with
0 instead of R_386_JMP_SLOT.  This is a bug of the linker.  If you can
reproduce this with recent AS2.1 versions with all updates, file a new
bug against binutils and include the output of readelf -r BINARY and
the object files used (or a recipe to produce them).

I'm closing the bug since it's no glibc issue at all.


Note You need to log in before you can comment on or make changes to this bug.