Bug 107342 - redhat-config-xfree86 writes incorrect XFree86Config for dual-head setup.
redhat-config-xfree86 writes incorrect XFree86Config for dual-head setup.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: redhat-config-xfree86 (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-16 23:40 EDT by Dan Nuffer
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-09 22:52:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Nuffer 2003-10-16 23:40:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031009

Description of problem:
I started redhat-config-xfree86, turned on "Use dual head", selected my
hardware, picked "Spanning Desktops" and clicked OK.  I then restarted X, but no
Xinerama :-(  Examining the XF86Config file, it appears to be incorrect.  It
contained this:

Section "Screen"
        Identifier "Screen1"
        Device     "Videocard0"
        Monitor    "Monitor1"
        DefaultDepth     24
        SubSection "Display"
                Depth     24
                Modes    "1600x1200"
        EndSubSection
EndSection


I Changed:
        Device     "Videocard0"
to
        Device     "Videocard1"
and all worked as it should.






Version-Release number of selected component (if applicable):
redhat-config-xfree86-0.9.9-2

How reproducible:
Always

Steps to Reproduce:
1. Run redhat-config-xfree86
2. turn on dual head
3. restart X
    

Actual Results:  Dual head (xinerama) wasn't enabled.

Expected Results:  Dual head (xinerama)

Additional info:
Comment 1 Brent Fox 2003-10-17 15:16:12 EDT
Try with redhat-config-xfree86-0.9.13-1 and see if that works.  You might try to
delete the existing XF86Config file and see if r-c-xfree86 creates a correct
dual-head file from scratch.
Comment 2 Dan Nuffer 2003-10-17 22:48:52 EDT
Updated to redhat-config-xfree86-0.9.12-1.
                                                                                
Still no luck :-(
                                                                                
I removed XF86Config, and re-ran redhat-config-xfree86.
Changed Resolution to 1600x1200, Color Depth to Millions of Colors, Hardware tab
was all correct, went to Dual head tab.  Checked "Use dual head", picked
"Hitachi CM751" as the monitor type. (Interestingly, my exact monitor model, the
Hitachi CM715 isn't in the list.  The 751 is a nearly identical older model. 
How do I get the CM715 added to the list?).  Changed Resolution to 1600x1200,
Color Depth to Millions of Colors and Desktop layout to Spanning Desktops. 
Clicked OK.
                                                                                
The generated file looked better than before, it has "Videocard1" instead of
"Videocard0", but it still doesn't work :-(

This time, the problem was this:

Section "Device"
        Identifier  "Videocard1"
        Driver      "mga"
        VendorName  "Videocard Vendor"
        BoardName   "Matrox Millennium G450"
        BusID       "PCI:1:5:0"
EndSection
                                                                                
I needed to add:
        Screen      1

in there to get it to work.
Comment 3 Dan Nuffer 2003-10-17 22:57:38 EDT
Just an additional note.  I had the same problem if I removed the XF86Config,
then generated a single-head configuration, and then tried to switch to a
dual-head config.
Comment 4 Dr. Peter Boy 2003-10-25 10:59:52 EDT
Just an additional note:

x-c-x does not add into Section Device / Identifier "Videocard0" the entries:
BusID  "PCI:1:0:0"   (in case of a Matrox G550 DVI Dual Head)
Screen 0

Both are not strictly required, but would contribute to a clear config file.

Perhaps you can add to the Monitor Database:

Vendor NEC
Modell:  MultiSync LCD 1700NX
HorizSync 31.5 - 80.0    (according to NEC manual)
VertRefresh  56.0-75.0

The 15 and 18 zoll model are included, but this one is missing.
Comment 5 Brent Fox 2004-03-09 22:52:54 EST
I believe the dual head code has been fixed with
system-config-display-1.0.10-1 in Rawhide.  Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.