Bug 1073537 - DS connection tests is required to pass across all servers
Summary: DS connection tests is required to pass across all servers
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web Console
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: DR3
: EAP 6.3.0
Assignee: Harald Pehl
QA Contact: Jakub Cechacek
Russell Dickenson
URL:
Whiteboard:
Depends On: 1072962
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-06 16:12 UTC by Jakub Cechacek
Modified: 2015-02-01 23:00 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In previous versions of JBoss EAP 6, the DS connection test used all servers in the domain. This could negatively impact performance. In this release of the product, only the servers of the currently selected profiles are used for the connection test, resulting in better, more reliable performance.
Clone Of:
Environment:
Last Closed: 2014-06-28 15:41:24 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
JBoss Issue Tracker HAL-384 Major Resolved DS connection tests is required to pass across all servers 2014-07-24 07:29:00 UTC

Description Jakub Cechacek 2014-03-06 16:12:04 UTC
For DS connection tests to succeed it currently has to pass across all servers instead only on those using currently selected profile. 

Steps to reproduce:

1) unzip distribution 
2) start EAP domain
3) start other-server-group
4) navigate to web console -> datasources
5) pick full profile and DISABLE DefaultDS
6) switch to full-ha profile and test connection to DefaultDS DS


actual result: Test failed
expected result: Test was successful 

The problem is in the composite operation used to execute this test (Only the second step should be present in this case) -- see bellow. Because of this I am also concerned about the performance of this solution in large domains (10s of nodes, 100s of servers). 



Request
{
    "address" => [],
    "operation" => "composite",
    "steps" => [
        {
            "operation" => "test-connection-in-pool",
            "address" => [
                ("host" => "master"),
                ("server" => "server-one"),
                ("subsystem" => "datasources"),
                ("data-source" => "ExampleDS")
            ]
        },
        {
            "operation" => "test-connection-in-pool",
            "address" => [
                ("host" => "master"),
                ("server" => "server-three"),
                ("subsystem" => "datasources"),
                ("data-source" => "ExampleDS")
            ]
        },
        {
            "operation" => "test-connection-in-pool",
            "address" => [
                ("host" => "master"),
                ("server" => "server-two"),
                ("subsystem" => "datasources"),
                ("data-source" => "ExampleDS")
            ]
        }
    ]
}

Comment 1 JBoss JIRA Server 2014-03-07 10:44:31 UTC
Harald Pehl <hpehl@redhat.com> updated the status of jira HAL-384 to Coding In Progress

Comment 2 JBoss JIRA Server 2014-03-07 13:02:22 UTC
Harald Pehl <hpehl@redhat.com> updated the status of jira HAL-384 to Resolved

Comment 3 Jakub Cechacek 2014-04-07 10:14:59 UTC
verified with 6.3.0.DR6


Note You need to log in before you can comment on or make changes to this bug.