Bug 1073540 - PPC64 VM fail to run when created with more than one cd-room (payload)
Summary: PPC64 VM fail to run when created with more than one cd-room (payload)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.5.0
Assignee: Vitor de Lima
QA Contact: Jiri Belka
URL:
Whiteboard: ppc
Depends On:
Blocks: 1154674
TreeView+ depends on / blocked
 
Reported: 2014-03-06 16:23 UTC by Leonardo Bianconi
Modified: 2015-06-22 00:11 UTC (History)
10 users (show)

Fixed In Version: 3.5.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 12:26:55 UTC
oVirt Team: ---
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 25632 0 master MERGED core, engine: Fix CD-ROM payload in ppc64 VMs Never
oVirt gerrit 25801 0 ovirt-engine-3.4 ABANDONED core, engine: Fix CD-ROM payload in ppc64 VMs Never
oVirt gerrit 33057 0 ovirt-engine-3.4 MERGED core, engine: Fix CD-ROM payload in ppc64 VMs Never

Description Leonardo Bianconi 2014-03-06 16:23:43 UTC
Description of problem:
When running a VM with two attached cd-room it fails with the error: "VM teste is down. Exit message: internal error: process exited while connecting to monitor: qemu-system-ppc64: -drive file=/var/run/vdsm/payload/64670fb8-c616-4c2b-baaf-cafc88c45daf.44504f22d90662acdf8b73371447de77.img,if=none,id=drive-scsi0-0-0-0,readonly=on,format=raw,serial=: Duplicate ID 'drive-scsi0-0-0-0' for drive"

Version-Release number of selected component (if applicable):
3.4

How reproducible:
100%

Steps to Reproduce:
1. Configure the environment with PPC64 hosts
2. Create a VM choosing an OS different from "Other OS"
3. Add a disk to the VM
4. Run the VM

Actual results:
VM fails to run with error: "Duplicate ID 'drive-scsi0-0-0-0' for drive"

Expected results:
VM runs without errors

Additional info:
This is a non blocker for 3.4 release, since trying to start the VM again or select the "Other OS", the VM runs with success.

Comment 1 Sandro Bonazzola 2014-05-08 13:55:04 UTC
This is an automated message.

oVirt 3.4.1 has been released.
This issue has been retargeted to 3.5.0 since it has not been marked as high priority or severity issue, please retarget if needed.

Comment 2 Jiri Belka 2014-10-10 14:11:26 UTC
ok, 3.4.3 (although workaround for creating vm was used - via restapi [balloon issue[)

Comment 3 Jiri Belka 2014-10-10 15:01:26 UTC
Target release: 3.5...

Comment 4 Jiri Belka 2014-10-10 15:28:22 UTC
Other OS/ppc64 starts OK with rhevm-backend-3.5.0-0.14.beta.el6ev.noarch

Comment 5 Sandro Bonazzola 2014-10-17 12:26:55 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.