Bug 1073548 - Engine requires /etc/mime.types
Summary: Engine requires /etc/mime.types
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.4
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
: 3.4.0
Assignee: Alon Bar-Lev
QA Contact: Pavel Stehlik
URL:
Whiteboard: integration
Depends On:
Blocks: 1024889
TreeView+ depends on / blocked
 
Reported: 2014-03-06 16:47 UTC by Alexander Wels
Modified: 2014-03-31 12:26 UTC (History)
7 users (show)

Fixed In Version: ovirt-engine-3.4.0_rc
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-31 12:26:16 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 25496 0 None MERGED packaging: spec: add mimecap dependency Never
oVirt gerrit 25508 0 None MERGED packaging: spec: add mailcap dependency Never
oVirt gerrit 25509 0 None MERGED packaging: spec: add mailcap dependency Never

Description Alexander Wels 2014-03-06 16:47:47 UTC
Description of problem:
If the system running the engine doesn't have /etc/mime.types there is a file not found exception in the engine log and the oVirt branding is not applied to any of the pages.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Rename /etc/mime.types, or somehow make it unavailable.
2. Start the engine.
3. Go to the welcome page.

Actual results:
Exception in log and unstyled page.

Expected results:
Warning in log and style page.

Additional info:

Comment 1 Alon Bar-Lev 2014-03-06 17:06:44 UTC
This is nice one!

Comment 2 Alon Bar-Lev 2014-03-06 17:10:41 UTC
Explicitly access at ServletUtils.java

Comment 3 Sandro Bonazzola 2014-03-07 07:39:04 UTC
Moving back to POST, please cherry pick the fix on 3.4 branch too.

Comment 4 Pavel Stehlik 2014-03-18 11:11:47 UTC
ok - av3 (rhevm d/s)

Comment 5 Sandro Bonazzola 2014-03-31 12:26:16 UTC
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released


Note You need to log in before you can comment on or make changes to this bug.