This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 10736 - Linuxconf segmentation faults when I run it
Linuxconf segmentation faults when I run it
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: linuxconf (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-11 19:16 EDT by alfred
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-09 06:56:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description alfred 2000-04-11 19:16:58 EDT
Linuxconf used to work fine after my initial install of RH6.1.
I recently upgraded to ; I don't know
if this action caused it to stop working or if it was something
else. I've tried several things, like reinstalling it (1.16r10)
using

   rpm -i --replacepkgs linuxconf-1.16r10-2.i386.rpm

It seems to reinstall properly, but it still crashes. I don't
know how to downgrade back to my older version to see if that
works.

Here is a backtrace using gdb, maybe it will mean something to
you:

Starting program: /bin/linuxconf

Program received signal SIGSEGV, Segmentation fault.
0x80c0453 in dialog_textsize ()
(gdb) bt
#0  0x80c0453 in dialog_textsize ()
#1  0x80c07cb in DIALOG::setup ()
#2  0x80c14db in DIALOG::edit ()
#3  0x80bfbc8 in dialog_msgbox ()
#4  0x80af43e in error_setmode ()
#5  0x80af466 in xconf_error ()
#6  0x8078e8a in daemon_find ()
#7  0x8078ea3 in daemon_findpath ()
#8  0x80b5334 in POPEN::initarg ()
#9  0x80b5472 in POPEN::POPEN ()
#10 0x80c9c1f in DIAJAVA::DIAJAVA ()
#11 0x80bcbf9 in diagui_init ()
#12 0x80bdb40 in dialog_clear ()
#13 0x80bdb85 in dialog_clearinit ()
#14 0x80c147a in DIALOG::edit ()
#15 0x80c0073 in dialog_textbox ()
#16 0x80701c2 in notice_show ()
#17 0x806f8e9 in linuxconf_main ()
#18 0x806df56 in main ()
#19 0x400f31eb in __libc_start_main (main=0x806d34c <main>, argc=1,
    argv=0xbffffc34, init=0x806c480 <_init>, fini=0x80cf1ec <_fini>,
    rtld_fini=0x4000a610 <_dl_fini>, stack_end=0xbffffc2c)
    at ../sysdeps/generic/libc-start.c:90
Comment 1 nathankirkham 2000-05-09 06:56:59 EDT
Try removing /etc/smb.conf . Mine had corrupted during a linuxconf crash a
trashed the file.
Comment 2 Trond Eivind Glomsrxd 2000-09-13 18:34:25 EDT
Try using the 6.2 linuxconf package; if the problem persists, please re-open.

Note You need to log in before you can comment on or make changes to this bug.