Bug 1073796 - [amqp1.0] delete-on-close policy do not work for producers of exchanges
Summary: [amqp1.0] delete-on-close policy do not work for producers of exchanges
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp
Version: 3.0
Hardware: All
OS: Linux
low
medium
Target Milestone: 3.1
: ---
Assignee: Pavel Moravec
QA Contact: Petr Matousek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-07 08:50 UTC by Pavel Moravec
Modified: 2015-04-14 13:47 UTC (History)
2 users (show)

Fixed In Version: qpid-cpp-0.30-2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-14 13:47:37 UTC
Target Upstream Version:


Attachments (Terms of Use)
Patch proposal (3.62 KB, patch)
2014-03-07 08:53 UTC, Pavel Moravec
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Apache JIRA QPID-5608 None None None Never
Red Hat Bugzilla 1059784 None None None Never
Red Hat Product Errata RHEA-2015:0805 normal SHIPPED_LIVE Red Hat Enterprise MRG Messaging 3.1 Release 2015-04-14 17:45:54 UTC

Internal Links: 1059784

Description Pavel Moravec 2014-03-07 08:50:29 UTC
Description of problem:
See bz1059784. This is the second part for producers of an exchange.

The delete-on-close lifetime policy is not applied to producers when the exchange is in use.


Version-Release number of selected component (if applicable):
qpid-cpp-*-0.22-35


How reproducible:
100%


Steps to Reproduce:
qpid-send --connection-options "{protocol:'amqp1.0'}" -a "exSend;{create:always, node:{type: topic, properties:{lifetime-policy:delete-on-close}}}" -m 100000 --send-rate=1 &
exSendPID=$!
sleep 1
qpid-send --connection-options "{protocol:'amqp1.0'}" -a "exSend;{create:always, node:{type: topic, properties:{lifetime-policy:delete-on-close}}}" -m 100000 --send-rate=1 &
sleep 1
kill $exSendPID
qpid-config exchanges exSend

Actual results:
- not-killed qpid-send is still running
- "qpid-config exchanges" shows:
Type      Exchange Name  Attributes
=============================================
topic     exSend        


Expected results:
- not-killed qpid-send should terminate after attempting to send to unkwnown exchange
- there should not be such exchange


Additional info:

Comment 1 Pavel Moravec 2014-03-07 08:53:08 UTC
Created attachment 871797 [details]
Patch proposal

Comment 2 Pavel Moravec 2014-03-07 10:35:06 UTC
Committed to upstream as revision r1575225.

Comment 3 Pavel Moravec 2014-03-09 20:33:37 UTC
(In reply to Pavel Moravec from comment #2)
> Committed to upstream as revision r1575225.

.. and Chuck corrected a typo in r1575441. Thanks Chuck!

Comment 5 Petr Matousek 2015-03-24 12:53:23 UTC
This issue has been fixed.
Verified on rhel6.6 (x86_64 and i386) and rhel7 (x86_64).

Packages:
  qpid-cpp-*-0.30-7

-> VERIFIED

Comment 7 errata-xmlrpc 2015-04-14 13:47:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0805.html


Note You need to log in before you can comment on or make changes to this bug.