Bug 1073827 - [engine-setup] UPDATE - Deploying Jasper fails: Failed to execute stage 'Misc configuration': port must be a string or int
Summary: [engine-setup] UPDATE - Deploying Jasper fails: Failed to execute stage 'Misc...
Keywords:
Status: CLOSED DUPLICATE of bug 1067058
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: ---
Assignee: Ofer Schreiber
QA Contact: Pavel Stehlik
URL:
Whiteboard: infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-07 10:05 UTC by Jiri Belka
Modified: 2016-02-10 19:27 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-11 07:25:17 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)
logs (385.93 KB, application/x-xz)
2014-03-07 10:05 UTC, Jiri Belka
no flags Details

Description Jiri Belka 2014-03-07 10:05:55 UTC
Created attachment 871826 [details]
logs

Description of problem:
I was doing update from 'av2' to 'av2.1'.

...
[ INFO  ] Backing up database localhost:ovirt_engine_reports to '/var/lib/ovirt-engine-reports/backups/reports-20140307104241.uKuwVM.sql'.
[ INFO  ] Deploying Jasper
[ ERROR ] Failed to execute stage 'Misc configuration': port must be a string or int
[ INFO  ] Yum Performing yum transaction rollback
[ INFO  ] Rolling back database schema
[ INFO  ] Clearing Engine database engine
[ INFO  ] Restoring Engine database engine
[ INFO  ] Rolling back DWH database schema
[ INFO  ] Clearing DWH database rhevm34_history
[ INFO  ] Restoring DWH database rhevm34_history
[ INFO  ] Rolling back Reports database schema
[ INFO  ] Clearing Reports database ovirt_engine_reports
[ INFO  ] Restoring Reports database ovirt_engine_reports
[ INFO  ] Rolling back Reports files
[ INFO  ] Stage: Clean up
          Log file is located at /var/log/ovirt-engine/setup/ovirt-engine-setup-20140307100841.log
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[ ERROR ] Execution of setup failed


...
2014-03-07 10:46:31 DEBUG otopi.plugins.ovirt_engine_setup.ovirt_engine_reports.jasper.deploy plugin.execute:446 execute-output: ('./js-ant', '-DmasterPropsSource=/tmp/tmpDK6
Drj/config', 'deploy-webapp-pro') stderr:


2014-03-07 10:46:31 DEBUG otopi.context context._executeMethod:138 Stage misc METHOD otopi.plugins.ovirt_engine_setup.ovirt_engine_reports.jasper.deploy.Plugin._artifacts
2014-03-07 10:46:31 DEBUG otopi.context context._executeMethod:138 Stage misc METHOD otopi.plugins.ovirt_engine_setup.ovirt_engine_reports.db.connection.Plugin._connection
2014-03-07 10:46:31 DEBUG otopi.context context._executeMethod:152 method exception
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/otopi/context.py", line 142, in _executeMethod
    method['method']()
  File "/usr/share/ovirt-engine/setup/bin/../plugins/ovirt-engine-setup/ovirt-engine-reports/db/connection.py", line 312, in _connection
    database=self.environment[oreportscons.DBEnv.DATABASE],
TypeError: port must be a string or int
2014-03-07 10:46:31 ERROR otopi.context context._executeMethod:161 Failed to execute stage 'Misc configuration': port must be a string or int
2014-03-07 10:46:31 DEBUG otopi.transaction transaction.abort:131 aborting 'Yum Transaction'
2014-03-07 10:46:31 INFO otopi.plugins.otopi.packagers.yumpackager yumpackager.info:92 Yum Performing yum transaction rollback
Loaded plugins: product-id, rhnplugin, versionlock
This system is receiving updates from RHN Classic or RHN Satellite.
...

Version-Release number of selected component (if applicable):
av2/av2.1
rhevm-setup-3.4.0-0.3.master.el6ev.noarch
rhevm-reports-setup-3.4.0-0.4.master.20140226133324.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. av2, av2.1 repos
2. engine-setup
3. 

Actual results:
failure after 'Deploying Jasper'

Expected results:
should pass OK

Additional info:
- following packages were update by Yum before `engine-setup' was done
Mar 07 09:58:05 Updated: otopi-1.2.0-0.7.rc2.el6ev.noarch
Mar 07 09:58:05 Updated: otopi-java-1.2.0-0.7.rc2.el6ev.noarch
Mar 07 09:58:05 Updated: rhevm-setup-plugins-3.4.0-0.0.master.20140304104652.el6ev.noarch
Mar 07 09:58:05 Updated: rhevm-branding-rhev-3.4.0-0.0.master.20140303202334.el6ev.noarch
Mar 07 09:58:59 Updated: jasperreports-server-pro-5.5.0-8.el6ev.noarch

- info about env:
  * engine with local DB
  * dwh with remote DB
  * reports with local DB

Comment 1 Yaniv Lavi 2014-03-11 07:25:17 UTC

*** This bug has been marked as a duplicate of bug 1067058 ***


Note You need to log in before you can comment on or make changes to this bug.