Bug 1073939 - Akonadi problem when home-dir is in AFS
Summary: Akonadi problem when home-dir is in AFS
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: akonadi
Version: 6.5
Hardware: Unspecified
OS: Linux
urgent
medium
Target Milestone: rc
: 6.6
Assignee: Daniel Vrátil
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 994246
TreeView+ depends on / blocked
 
Reported: 2014-03-07 14:16 UTC by Martin Schuppert
Modified: 2018-12-05 17:35 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the Akonadi service used the hard-coded ~/.local/share/akonadi socket directory. As a consequence, the Akonadi server did not start if the home directory was located on Andrew File System (AFS), which did not support the creation of UNIX sockets. With this update, the directory that holds the sockets has been changed to '/tmp/[username]-akonadi.[random]'. As a result, Akonadi starts on systems with the home directory on AFS as expected.
Clone Of:
Environment:
Last Closed: 2014-05-26 07:16:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
KDE Software Compilation 179006 None None None Never
Red Hat Product Errata RHBA-2014:0539 normal SHIPPED_LIVE akonadi bug fix update 2014-05-26 11:16:38 UTC

Description Martin Schuppert 2014-03-07 14:16:56 UTC
Description of problem:
akonadi server does not start if the home directory is in afs space which does not allow creation of unix sockets (and named pipes). The socket paths in the source are somehow hardcoded to be in ~/.local/share/akonadi/akonadiserver.socket and ~/.local/share/akonadi/db_misc/mysql.socket. Is it possible to move it to /tmp/kde-username or /var/tmp/kdecache-usernameXXXXX?

Version-Release number of selected component (if applicable):
akonadi-1.2.1-2.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. use home dirs on AFS
2.
3.

Actual results:
akonadi server does not start

Expected results:
akonadi server does not start

Additional info:
From https://bugs.kde.org/show_bug.cgi?id=179006#c12 upstream patch available.

~~~
 Use symlink to /tmp as socket directory by default 

This patch is based on the one written by Ansgar Burchardt to use a socket directory linked to /tmp/<username>-akonadi.<random> instead of the hard-coded one from ~/.local/share/akonadi. With this patch Akonadi will start on systems with $HOME on AFS without any further configuration needed.
~~~

Comment 15 Martin Schuppert 2014-04-25 13:41:45 UTC
Created attachment 889763 [details]
logs

Comment 23 Daniel Vrátil 2014-05-05 14:55:23 UTC
Pushed to rhel-6.6 branch.

Brew build: http://brewweb.devel.redhat.com/brew/taskinfo?taskID=7416522

Comment 29 errata-xmlrpc 2014-05-26 07:16:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0539.html


Note You need to log in before you can comment on or make changes to this bug.